Conversion of & to & while opening links.

RESOLVED INVALID

Status

()

RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: anurag.s.rana, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

The W3C XHTML 1.0 Strict Standard wants all variables in a GET query to be
separated by & and not &. Even if the user specifies & Firefox makes it
& and thus the newly opened page gives the error of being "not compliant to W3C
XHTML 1.0 Strict"
By clicking on any image at
http://students.iiit.ac.in/~anurag_rana/pics.php?album=shop, we get a link with
problems. If we click on the "W3C validator" on that page, it tells us that its
not W3C XHTML Strict. If we change the link to "&", it works. Really
annoying to see that a "correctly formatted" page is shown "not correct" because
of this so called "conversion of & to &"

Reproducible: Always

Steps to Reproduce:
1.Open http://students.iiit.ac.in/~anurag_rana/pics.php?album=shop
2.Click on any image.
3.
a.Click on the W3C XHTML 1.0 validator image on the page.
b.Change the & in the URL to & and then click the validator.


Actual Results:  
Case 'a' gives bad result and 'b' gives good result. (Refering to steps above).

Expected Results:  
The links opened with Firefox should not convert & in the URL to &.

Comment 1

13 years ago
This is no way a firefox problem. Tell the webmaster of that site to use
htmlentities() on his his hidden input type called 'reurl'.

Since this doesn't affect cross-browser compatibility, I'm not reassigning to
tech evangelism.

-->INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.