already existing bookmarks are still added when importing from IE

VERIFIED DUPLICATE of bug 271437

Status

()

VERIFIED DUPLICATE of bug 271437
13 years ago
13 years ago

People

(Reporter: james, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

** I hope this is not a duplicate - there is a lot of junk is this category **

I imported my IE favorites once - then after use IE again for some dev work,
wanted to sync so I re-imported my favorites from IE. This resulted in my
already imported IE favorites being imported a second time: a mess that was a
bit of a pain to clean up!

Also, the same page can be bookmarked twice - which is sort of pointless. A
alert dialog "This page has already been added to your bookmarks in [folder
name]" would be just fine. The reason I add [folder name] is because I (and I am
sure others) will often find a killer css site (like the listamatic) for a the
second time and add naturally add it to my bookmarks (for the second time). 

You can also add: Click HERE to manage your books marks or click here to CLOSE.
(If you click HERE the folder with the page you were trying to add is
automatically opened)

So the simple fix - keep bookmarks unique (URLs only _not_ URLs and name)

You can also create folders of the same name more than once - which is not
necessarily a terrible bug rather just illogical.

I am sure that you have enough people asking for a synchronization module -
perhaps between different browsers or even different pcs. This is one step in
the right direction.

Reproducible: Always

Steps to Reproduce:
1. Just add a bookmark twice
2. Look in Manage Bookmarks

Actual Results:  
I have exactly the same bookmark twice.

Expected Results:  
A alert dialog "This page has already been added to your bookmarks in [folder
name]" would be just fine. Click HERE to manage your books marks or click here
to CLOSE. (If you click HERE the folder with the page you were trying to add is
automatically opened)
There is an extension for this function, the Bookmark Duplicate Detector. I
think it is discutable if IE's way is better. Sometimes IE did not accept that
two bookmarks were really different; very annoying.

Comment 2

13 years ago
(In reply to comment #0)
> I imported my IE favorites once - then after use IE again for some dev work,
> wanted to sync so I re-imported my favorites from IE. This resulted in my
> already imported IE favorites being imported a second time.

Related to/duplicate of bug 280682?
 
> Also, the same page can be bookmarked twice - which is sort of pointless. 

Duplicate of bug 284997 -> bug 220049.

*** This bug has been marked as a duplicate of 271437 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.