If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

View source on dynamic pages downloads page again

VERIFIED DUPLICATE of bug 6119

Status

SeaMonkey
General
P3
normal
VERIFIED DUPLICATE of bug 6119
18 years ago
13 years ago

People

(Reporter: Gwyn Judd, Assigned: Alec Flett)

Tracking

Trunk
PowerPC
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; N; Linux 2.2.14 ppc; en-US; m14)
BuildID:    2000031215

When you select view source on a page that is dynamically generated, it will
download the page again instead of using the page that is already in memory.

Reproducible: Always
Steps to Reproduce:
1. Choose view source for the above url


Actual Results:  The view source window came up and the source was displayed.
However before this it downloaded the page again, instead of using the currently
loaded page. I could tell it did this because the message "transferring data
from www.slashdot.org" was displayed in the status bar along with the funny
stripes and I could see the modem lights flashing while it did this.

Expected Results:  I think it should use the page it is currently displaying. I
wonder if it does this because the page has expired? If this is the case then I
think it should still display source for the currently displayed page so as to
minimise the surprise

Comment 1

18 years ago

*** This bug has been marked as a duplicate of 6119 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
Obsolete DOM Viewer bugs -> Browser-General; DOM Viewer component is going away.
Component: DOM Viewer → Browser-General
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.