If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Mac updater description string is cropped

RESOLVED FIXED in mozilla1.8final

Status

()

Toolkit
Application Update
P1
major
RESOLVED FIXED
12 years ago
9 years ago

People

(Reporter: mano, Assigned: mano)

Tracking

({regression, verified1.8})

1.8.0 Branch
mozilla1.8final
PowerPC
Mac OS X
regression, verified1.8
Points:
---
Bug Flags:
blocking1.8b5 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

The mac updater description string is cut right after the word "few".
Summary: Mac updater description string is cut → Mac updater description string is cropped
Created attachment 194048 [details]
Screenshot
Flags: blocking1.8b4?
Target Milestone: --- → Firefox1.5
Created attachment 194050 [details]
new nib
Assignee: joshmoz → bugs.mano
Status: NEW → ASSIGNED
Attachment #194050 - Flags: review?(joshmoz)
Keywords: regression
Priority: -- → P1

Comment 3

12 years ago
*** Bug 306215 has been marked as a duplicate of this bug. ***

Updated

12 years ago
Flags: blocking1.8b4? → blocking1.8b4+
Attachment #194050 - Flags: review?(joshmoz) → review?(mark)
Created attachment 194226 [details]
keyedobjects.nib
Attachment #194226 - Flags: review?(mark)
Attachment #194050 - Attachment is obsolete: true
Attachment #194050 - Flags: review?(mark)

Updated

12 years ago
Attachment #194226 - Flags: review?(mark) → review+
Attachment #194226 - Flags: approval1.8b4?
*** Bug 306367 has been marked as a duplicate of this bug. ***
Checking in Contents/Resources/English.lproj/MainMenu.nib/keyedobjects.nib;
/cvsroot/mozilla/toolkit/mozapps/update/src/updater/macbuild/Contents/Resources/English.lproj/MainMenu.nib/keyedobjects.nib,v
 <--  keyedobjects.nib
new revision: 1.5; previous revision: 1.4
done
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Updated

12 years ago
Attachment #194226 - Flags: approval1.8b4? → approval1.8b4+
1.8 Branch:
Checking in Contents/Resources/English.lproj/MainMenu.nib/keyedobjects.nib;
/cvsroot/mozilla/toolkit/mozapps/update/src/updater/macbuild/Contents/Resources/English.lproj/MainMenu.nib/keyedobjects.nib,v
 <--  keyedobjects.nib
new revision: 1.4.2.1; previous revision: 1.4
done
Keywords: fixed1.8

Comment 8

12 years ago
Asaf, it's hard totell from this binary patch what changed to fix this. Did we
end up shortening the string or making the dialog wider to accomodate the text?
Blocks: 306127
This has made the label as wide as the progress bar in the updater window.
(In other words, no strings changes)
Looks good using Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
rv:1.8b5) Gecko/20050929 Firefox/1.4. Adding verified keyword.
Keywords: fixed1.8 → verified1.8
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.