Closed Bug 306190 Opened 17 years ago Closed 17 years ago

Firefox.exe hangs with 99% CPU usage when clearing Download Manager.

Categories

(Toolkit :: Downloads API, defect)

x86
Windows XP
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 273244

People

(Reporter: wocerew, Unassigned)

Details

(Keywords: hang)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

Firefox.exe hangs and CPU usage rises to 99% if any attempt is made to clear any
one or all Download Manager items.

Reproducible: Always

Steps to Reproduce:
Problem occurred if any of the following was done:

1. "Clear" button was clicked in Tools/Options/Privacy/Download Manager History
2. "Clear" button was clicked in Download Manager window
3. Any single item was selected to clear from Download Manager window
4. "When Firefox exits" was selected to Remove files from the Download Manager
in Tools/Options/Privacy/Download Manager History. (This caused Firefox to hang
on exit)
Actual Results:  
Firefox.exe would hang, with 99% CPU usage shown in Windows Task Manager, and no
error message.  If clearing Download Manager was attempted by clicking on a
Clear button, all Firefox windows would hang open.  If Firefox tried to
automatically clear when exiting, all Firefox windows would close, but
firefox.exe would still be running with 99% CPU usage in Task Manager.

Expected Results:  
Firefox should have cleared the Download Manager history and resumed normal
operation.

1. Problem occurs in both normal and safe modes.
2. downloads.rdf file in user profile was 2.18MB when problem was first noticed
(problem could have existed earlier, but can't verify)
3. Renaming/removing downloads.rdf and restarting Firefox fixed the problem.
4. Copying original downloads.rdf back to original location made problem re-appear.
5. Examination of downloads.rdf doesn't reveal any obvious corruption.
Do you see this in safe mode? http://kb.mozillazine.org/Safe_mode
Severity: normal → critical
Keywords: hang
(In reply to comment #1)
> Do you see this in safe mode? http://kb.mozillazine.org/Safe_mode

Please see my first comment after Expected Results:
"1. Problem occurs in both normal and safe modes."
Related to Suite bug 161783?
Same here... When I tried to clear download history from Download Manager window
or via Options, computer hangs with 100% cpu usage.
Size of file downloads.rdf was 1.14MB, I had to delete it manually...
Addional remark:  This is probably related.  Before clearing by deleting
downloads.rdf, Firefox would also respond very slowly when downloading images
with right click/Save Image As...   Sometimes 10 seconds or more would elapse
before Firefox would respond and notify that even a small download (<10kb, on
4Mb/s connection) had completed.  Since reporting the bug, I've set Options to
"Clear after successful download".  Response when downloading images is
immediate, and Firefox hasn't hung since.
Could you guys download the new Firefox 1.5 Beta 1 and tell me if you're still
seeing this? http://www.mozilla.org/projects/firefox/
Bug 242521, Bug 273244 and Bug 306190(this bug) look to be same problem.
Bug 273244
Download Manager - memory usage increases when opening/removing files - memory is not reclaimed

*** This bug has been marked as a duplicate of 273244 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.