Focus is lost on filtering in Cookies/Permissions dialogs

RESOLVED FIXED in Firefox 2 alpha1

Status

()

Firefox
Preferences
--
minor
RESOLVED FIXED
13 years ago
12 years ago

People

(Reporter: Simon Bünzli, Assigned: Simon Bünzli)

Tracking

({fixed1.8.1})

2.0 Branch
Firefox 2 alpha1
fixed1.8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050826 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050826 Firefox/1.0+

These three dialogs can't be closed using the Escape key, while all other
preferences dialogs can. While these are non-modal dialogs sporting a Close
button (instead of modal with OK/Cancel), I'd still expect Escape to work since
even Bookmarks/Download/Extension/Themes managers can be closed this way.

Additionaly selecting Clear in the Download actions/Cookies dialogs leaves the
focus on the disabled button - which you certainly won't want, if you cleared
the filter using [Alt]+[L] and would like to go on filtering right away.

Reproducible: Always

Steps to Reproduce:
1. Open e.g. the Cookies dialog (Tools -> Options -> Privacy -> Cookies -> View
Cookies).
2. Filter for "bugzilla" and hit [Alt]+[L]
3. Try to filter for "slashdot", quit your attempt with [Esc]

Actual Results:  
You have to hit [Shift]+[Tab] before step 3 (or use the mouse) and the dialog
remains open afterwards - unless you close it with [Ctrl]+[W] (which I'd rather
use for windows instead of dialogs), [Alt]+[C], [Alt]+[F4] or using the mouse.

Expected Results:  
No further keys have to be pressed.

Against the first point, you might argue that these seemingly non-modal dialogs
are actually windows as are View Source or the DOM Inspector (which are closed
using [Ctrl]+[W]). However, these feature a menu bar and no Close button, which
IMHO is a more intuitive indicator for "window-ness".

*** This bug has been marked as a duplicate of 283613 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 2

13 years ago
Created attachment 194054 [details] [diff] [review]
make ESC close these dialogs, reset focus on filter clearing
Attachment #194054 - Flags: review?(bryner)
(Assignee)

Comment 3

13 years ago
Created attachment 194056 [details] [diff] [review]
reset focus on filter clearing

Requesting reopening for the second issue (focus is lost on disabled button on
filter clearing).
Attachment #194054 - Attachment is obsolete: true
Attachment #194056 - Flags: review?(bryner)
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Attachment #194054 - Flags: review?(bryner)
(Assignee)

Updated

13 years ago
Summary: Minor accessability corrections for Download actions/Cookies/Permissions → Focus is lost on filtering in Cookies/Permissions dialogs

Comment 4

13 years ago
Confirmed on Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b4)
Gecko/20050908 Firefox/1.4
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attachment #194056 - Flags: review?(bryner) → review+
(Assignee)

Updated

12 years ago
Attachment #194056 - Flags: superreview?(firefox)
Comment on attachment 194056 [details] [diff] [review]
reset focus on filter clearing

No sr needed (and Blake isn't reviewing Firefox patches, see http://www.mozilla.org/projects/firefox/review.html).
Attachment #194056 - Flags: superreview?(firefox)
Assignee: nobody → zeniko
Target Milestone: --- → Firefox 2 alpha1
Version: unspecified → 2.0 Branch
Checked in on the trunk and the 1.8 branch for Firefox 2.

mozilla/browser/components/preferences/downloadactions.js 	1.9
mozilla/browser/components/preferences/cookies.js 	1.12

mozilla/browser/components/preferences/downloadactions.js 	1.5.2.3
mozilla/browser/components/preferences/cookies.js 	1.9.2.3
Status: NEW → RESOLVED
Last Resolved: 13 years ago12 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.