Text file address import

VERIFIED FIXED

Status

P3
enhancement
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: shwag, Assigned: tonyr)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Most programs can export to text files.  Make it so that the address book import
can pull up the fields of a tab or comma dillimeated text file and then allow
you to till it which number field stands for what type of field (first name,
last name, email, number, Pager, ect.)

Comment 1

19 years ago
Import of address books as text files is already implemtented. Go to
"Menu:Tasks->Tools->Import Utility". There is import text files.

But I suggest to either call this Import Utility when choosing
"Menu:File->Import..." in Adress book, or add the specific supported file types
in the open file dialog which appears after "import...".
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

19 years ago
Tony sending to you for confirmation.  If this is working then please close the 
bug.
Assignee: hangas → tonyr
(Assignee)

Comment 3

19 years ago
Yes, the import utility will import text files, comma or tab separated.  There 
may be some improvement that can be made to the UI for importing address books 
specifically.  Not sure if anyone would want to revisit that after beta1?  I'll 
close this unless I hear otherwise.

Comment 4

19 years ago
Close it.
Just one dumb question. Why is the import Utility not connected to the 
File->Import menu entry of addressbook where you only can import LDIF(???) 
files. If you don't know there is a import utility, it is hard to find.
On the other hand you wouldn't need that Tools->Import Utility entry all the 
time in each browser window.

Comment 5

19 years ago
ccing jglick to get opinion on the second Import menu item.  I have been confused 
by this as well.

Updated

19 years ago
QA Contact: lchiang → esther

Comment 6

19 years ago
Is the question, where should the Import menu item go?  In the Tasks, Tools menu 
or in each sep app File menu? Or both?

I guess I go back and forth on this one.  

Do we think of this as a global tool or an app specific tool?  If its app 
specific, it should be in the File menu, and if its global, in the Tasks menu.

Comment 7

19 years ago
Both would be fine, although I'd intuitivly expect it in the addressbook app. As 
that is the only place where importing addresses makes sense. So I'd vote for 
that.

But if existing, the two entries should never lead to different dialogs (as 
now). Because when a user discovered one, he will not try the other possibility 
and therefore miss important import features as been in the original bug the 
case.
(Assignee)

Comment 8

19 years ago
Not sure what the final resolution on the UI was but importing text is available.  
If there's still discussion on which menu import should go in then maybe someone 
should file a new bug on that?
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 9

19 years ago
Using build 2000-03-29-09 on win98 & linux and 200-03-29-08 on Mac this is 
working by use of the Import Utility.   I've logged a separate bug (33783)for 
the Menu item in the Address book window not importing all files or doing it the 
same way as the Utility.  Verifying this bug as orginally stated.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.