Allow to easily filter errors by category

RESOLVED FIXED in mozilla1.8.1beta2

Status

Toolkit Graveyard
Error Console
--
enhancement
RESOLVED FIXED
12 years ago
10 months ago

People

(Reporter: Simon Bünzli, Assigned: Simon Bünzli)

Tracking

({fixed-seamonkey1.1a, fixed1.8.1})

Trunk
mozilla1.8.1beta2
fixed-seamonkey1.1a, fixed1.8.1
Bug Flags:
blocking1.8b5 -
blocking-firefox2 -

Details

(Whiteboard: [verified-seamonkey1.1a])

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050827 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050827 Firefox/1.0+

The attached one-line patch allows extensions to very easily filter out unwanted
categories. This would come in handy, as the JS Console is about to be used for
non-JS warnings/errors as well.

Reproducible: Always

Steps to Reproduce:
(Assignee)

Comment 1

12 years ago
Created attachment 194084 [details] [diff] [review]
patch
Attachment #194084 - Flags: review?(vladimir)
Maybe a dupe of bug 302211
(Assignee)

Comment 3

12 years ago
Bug 302211 is a request to add filtering UI or a pref. This bug is just about a
back-end patch, providing a standard method for extension authors (such as
myself) to add the UI.

Updated

12 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk

*** This bug has been marked as a duplicate of 275265 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 5

12 years ago
No duplicate of bug 275265, either, since that bug is also about UI, while this
one is about a simple back-end change (see the attached patch).
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 6

12 years ago
What are the chances of seeing either this one or one of the two dupe candidates
(bug 302211 and bug 275265) fixed in time for Firefox 1.5?

This would considerably speed up the console's loading time when Console Filter
is installed (cf. http://forums.mozillazine.org/viewtopic.php?p=1734462#1734462
). In general, the attached patch would allow for a much cleaner way of
filtering the console without having to dive into XBL idiosyncracies, allowing
to use either CSS or JS for filtering - making it thus more straightforward for
extensions to provide any of the functionality of the mentioned bugs.
Flags: blocking1.8b5?

Comment 7

12 years ago
We're too far into this release to be considering feature additions like this.
You should work on getting this landed on the trunk for the next major release
after 1.5.
Flags: blocking1.8b5? → blocking1.8b5-

Updated

12 years ago
Depends on: 275265

Updated

11 years ago
Attachment #194084 - Flags: review?(vladimir) → review+
Whiteboard: [checkin needed]
Assignee: nobody → zeniko
Status: REOPENED → NEW
mozilla/toolkit/components/console/content/consoleBindings.xml 	1.10
Status: NEW → RESOLVED
Last Resolved: 12 years ago11 years ago
Resolution: --- → FIXED
Whiteboard: [checkin needed]
Target Milestone: --- → Firefox 3
(Assignee)

Comment 9

11 years ago
Since bug 312962 seems to be going nowhere, this one-line patch would at least make it considerably easier for extension authors to work around the console's current limitations.
Flags: blocking-firefox2?
Target Milestone: Firefox 3 → Firefox 2 beta2
(Assignee)

Updated

11 years ago
Attachment #194084 - Flags: approval1.8.1?
Not going to block on this, but will take the patch?
Flags: blocking-firefox2? → blocking-firefox2-

Updated

11 years ago
Attachment #194084 - Flags: approval1.8.1? → approval1.8.1+
Whiteboard: [checkin needed (1.8 branch)]
mozilla/toolkit/components/console/content/consoleBindings.xml 	1.9.2.1
Keywords: fixed1.8.1
Whiteboard: [checkin needed (1.8 branch)]
Blocks: 344955
Created attachment 229629 [details] [diff] [review]
(Bv1-XPFE) <consoleBindings.xml>
[Checkin: Comment 14 & 16]

[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.1b1) Gecko/20060717 SeaMonkey/1.1a] (nightly) (W98SE)

Port Toolkit patch to XPFE.

I've been running with this for half a day, without noticing any issue:
warnings/errors/exceptions still display as before.
Attachment #229629 - Flags: superreview?(neil)
Attachment #229629 - Flags: review?(neil)

Updated

11 years ago
Attachment #229629 - Flags: superreview?(neil)
Attachment #229629 - Flags: superreview+
Attachment #229629 - Flags: review?(neil)
Attachment #229629 - Flags: review+
Whiteboard: [checkin needed: Bv1-XPFE]
Comment on attachment 229629 [details] [diff] [review]
(Bv1-XPFE) <consoleBindings.xml>
[Checkin: Comment 14 & 16]

'approval1.8.1=?': (XPFE only)
Trivial U.I. code addition, sync'ing with Toolkit, no risk.
Attachment #229629 - Flags: approval1.8.1?
Checking in consoleBindings.xml;
/cvsroot/mozilla/xpfe/components/console/resources/content/consoleBindings.xml,v
  <--  consoleBindings.xml
new revision: 1.25; previous revision: 1.24
done

Checked Bv1-XPFE patch in on trunk.
Whiteboard: [checkin needed: Bv1-XPFE]
Comment on attachment 229629 [details] [diff] [review]
(Bv1-XPFE) <consoleBindings.xml>
[Checkin: Comment 14 & 16]

a=drivers. Please go ahead and land this on the branch.
Attachment #229629 - Flags: approval1.8.1? → approval1.8.1+
Checking in consoleBindings.xml;
/cvsroot/mozilla/xpfe/components/console/resources/content/consoleBindings.xml,v
  <--  consoleBindings.xml
new revision: 1.23.8.2; previous revision: 1.23.8.1
done

Checked Bv1-XPFE patch in on 1.8.1 branch.
Attachment #229629 - Attachment description: (Bv1-XPFE) <consoleBindings.xml> → (Bv1-XPFE) <consoleBindings.xml> [Checkin: Comment 14 & 16]
Attachment #229629 - Attachment is obsolete: true
Keywords: fixed-seamonkey1.1a
[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.1b1) Gecko/20060725 SeaMonkey/1.1a] (nightly) (W98SE)

V.Fixed on MOZILLA_1_8_BRANCH, by looking at packaged file, since this code is not directly used.
Whiteboard: [verified-seamonkey1.1a]
No longer blocks: 344955
Product: Firefox → Toolkit
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.