Do not use --disable-shared for building Thunderbird

RESOLVED INVALID

Status

Thunderbird
Build Config
--
critical
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: Patrick Brunschwig, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
Recent nightly builds are created with the option --disable-shared active.
However, this makes it impossible to have Enigmail running. The core of Enigmail
is a shared libary which cannot be loaded with this option enabled.

Recent nightly builds just crash with a segfault when Enigmail is accessed.
(Assignee)

Comment 1

12 years ago
I don't think this is the cause of the problem you are seeing Patrick. We've
always released static builds on (i.e. --disable-shared) on all platforms since
Thunderbird 0.7 or so. 
(Reporter)

Comment 2

12 years ago
Right, I'm sorry.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.