Closed Bug 306267 Opened 16 years ago Closed 15 years ago

Can't easily put caret in vBulletin designmode iframe

Categories

(Core :: DOM: Editor, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

VERIFIED FIXED

People

(Reporter: martijn.martijn, Assigned: mozeditor)

References

()

Details

(Keywords: regression, testcase)

Attachments

(1 file)

In current trunk build it is difficult to get the caret in an iframe with the
vBulletin designmode iframe.
See upcoming testcase.

When cicking in the designmode iframe, but outside the bordered box, you should
in both occasions get a caret in the bordered box.
It only happens easily in the right iframe.
In the left iframe, you have to click in the bordered box to get the caret.
After the first time, that isn't necessary anymore, and you can click anywere to
get the caret.
Attached file testcase
This regressed very badly (you couldn't place the caret or type anywhere at all
in the left frame of the testcase) sometime between 2005-01-26 and 2005-03-15,
and was then restored to the current, semi-broken, state between 2005-04-05 and
2005-04-07.

I'll try to work tomorrow on narrowing the first window, and findig candidates
for semi-fixing it during the second window (unless someone wants to do this
while I'm asleep).
Ah, forget about tomorrow.

Bug 209020 is probably the original regression (at Feb. 24th), and bug 283897
fixed that and brought it to the current state.
Keywords: regression
Flags: blocking1.9a1?
*** Bug 319935 has been marked as a duplicate of this bug. ***
Blocks: 320355
This bug makes it appear impossible to type into vBulletin, netscape.com email, and supportwizard forms.  At least one user didn't figure out that they could type despite the lack of a visible caet.  Nominating for Firefox 1.5.0.1.
Flags: blocking1.8.0.1?
Also seems to affect caramail.com, a popular French webmail site.
A tested fix would probably get approved (small, safe, etc), but it doesn't look like anyone's even working on this one -- not blocking 1.8.0.1
Flags: blocking1.8.1?
Flags: blocking1.8.0.1?
Flags: blocking1.8.0.1-
No problem anymore with 2006-04-18 trunk build on windows. Testcase is worksforme now. Fixed by bug 287813.
Status: NEW → RESOLVED
Closed: 15 years ago
Depends on: 287813
Resolution: --- → FIXED
Flags: blocking1.9a1?
Verified FIXED with testcase https://bugzilla.mozilla.org/attachment.cgi?id=194116&action=view on build 2006-04-28-05 of SeaMonkey trunk under Windows XP.
Status: RESOLVED → VERIFIED
There's still a case where the caret doesn't show up that easily, I filed bug 335856 for that.
Not going to block 1.8.1 for this bug, but we'll happily consider a low-risk patch if one appears.
Flags: blocking1.8.1? → blocking1.8.1-
You need to log in before you can comment on or make changes to this bug.