Browser hangs after clicking "Options" button

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
13 years ago
10 years ago

People

(Reporter: pehu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20050816 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20050816 Firefox/1.0+

If I attempt to view/alter the options for an extension in Deer Park, the
browser hangs.

Reproducible: Always

Steps to Reproduce:
1. Open the Extensions management window, by choosing Tools -> Extensions
2. Select an extension by clicking on it
3. Click the "Options" button
3a. Alternatively, double click the extension selected in step 2

Actual Results:  
The Extensions management window stops responding, and can only be closed using
the Windows Task Manager.

Expected Results:  
The options for the selected Extension should have opened (presumeably in its
own window).

I have tried this using the following extensions (that used to work in Firefox
1.0.6): Colorzilla, PrefBar, ImageZoom.
There were some significant issues of this sort on the trunk recently. Please
retest on a more recent nightly.
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> There were some significant issues of this sort on the trunk recently. Please
> retest on a more recent nightly.

OK, I will do that, as soon as a more recent build becomes available.
(Reporter)

Comment 4

13 years ago
(In reply to comment #3)
> Builds are made ever day:
> http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/

I am currently signed up on a beta program to test an extension that is aimed at
the _branch_ build 1.0+ (Deer Park). According to the person running the beta
program, the 1.6a1 builds do not support his extension, and I am instructed to
download the 1.0+ version. The latest build of that was 16-Aug-2005 10:58.
My apologies, I pointed you to the trunk directory because you already have a
trunk build installed (see the 1.9a1 in your user agent string).

The branch builds are available daily too:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla1.8/
(Reporter)

Comment 6

13 years ago
(In reply to comment #5)
> My apologies, I pointed you to the trunk directory because you already have a
> trunk build installed (see the 1.9a1 in your user agent string).
> 
> The branch builds are available daily too:
> http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla1.8/

Thanks, the latest build fixes the problem. The address I was given to download
from was this:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/ which
contains an older branch build than the current one. Perhaps it should be kept
in synch with the latest build from
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla1.8/ to
avoid confusion?

Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Updated

13 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 7

13 years ago
No patch, no known bug to dupe to -> WorksForMe
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

13 years ago
The correct resolution should be FIXED, since the bug was fixed in a newer
build, and the
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/ directory
has now been updated with the latest branch build.

Comment 9

13 years ago
Yes some bug fixed this but it was not this bug. Searching through the 3000 plus
 bugs that have been fixed since the 1.7 branch and finding the bug to dupe this
bug to is a waste of time. As this is no longer a problem an acceptable
resolution is WFM.
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.