crash in nsFilePicker.cpp on OSX

VERIFIED FIXED

Status

Core Graveyard
Widget: Mac
--
critical
VERIFIED FIXED
13 years ago
8 years ago

People

(Reporter: Shane Caraveo, Assigned: Shane Caraveo)

Tracking

({crash, verified1.8})

1.8 Branch
PowerPC
Mac OS X
crash, verified1.8

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

If you use too many file filters, you can crash and burn.  patch that fixes the
crash to be attached...

Reproducible: Always

Steps to Reproduce:
(Assignee)

Comment 1

13 years ago
Created attachment 194207 [details] [diff] [review]
fix for crash in nsFilePicker.cpp
(Assignee)

Updated

13 years ago
Component: General → XP Toolkit/Widgets
Product: Firefox → Core
Version: unspecified → 1.8 Branch
ccing a bunch of mac folks

Updated

13 years ago
Assignee: nobody → joshmoz
Component: XP Toolkit/Widgets → Widget: Mac
QA Contact: general → mac

Updated

13 years ago
Keywords: crash

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

13 years ago
Comment on attachment 194207 [details] [diff] [review]
fix for crash in nsFilePicker.cpp

Looks good. Thanks for the patch!

We may want to consider some kind of warning to the console if you use too many
filters, since it seems some are going to get ignored silently.
Attachment #194207 - Flags: review+

Updated

13 years ago
Attachment #194207 - Flags: superreview+
Assignee: joshmoz → shanec

Updated

13 years ago
Attachment #194207 - Flags: approval1.8b4?

Comment 4

13 years ago
This is a very safe patch, and should go in on the branch.

Updated

13 years ago
Attachment #194207 - Flags: approval1.8b4? → approval1.8b4+

Comment 5

13 years ago
checked in on trunk and 1.8 branch
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Updated

13 years ago
Keywords: fixed1.8

Updated

12 years ago
Status: RESOLVED → VERIFIED
Keywords: fixed1.8 → verified1.8

Updated

8 years ago
Component: Widget: Mac → Widget: Mac
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.