Date selector controls get the system date format incorrectly

RESOLVED FIXED

Status

Calendar
Sunbird Only
RESOLVED FIXED
13 years ago
12 years ago

People

(Reporter: Gary van der Merwe, Assigned: Mostafa Hosseini)

Tracking

Trunk
x86
Windows XP

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
The date controls (eg. From and To date on event form, Date and Due Date on task
form) are unusable. They default to the current date but in the format
yyyy/MM/yyyy. When you try correct it, it changes to "Invalid Date".

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050828 Mozilla
Sunbird/0.2+

Comment 1

13 years ago
(In reply to comment #0)
> The date controls (eg. From and To date on event form, Date and Due Date on task
> form) are unusable. They default to the current date but in the format
> yyyy/MM/yyyy. When you try correct it, it changes to "Invalid Date".
> 
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050828 Mozilla
> Sunbird/0.2+

This is quite odd.  The datepicker should default to the date in the format
specified by your system.  What format do dates appear for you in Windows? 
Also, just so we're clear 'yyyy/MM/yyyy' wasn't a typo?  There's no 'dd' anywhere?

Can you also double check that this happens in all datepickers? (try View->Go to
Date)

(Reporter)

Comment 2

13 years ago
Created attachment 194419 [details]
Screen Shot

>What format do dates appear for you in Windows? 
yyyy/MM/dd

>Also, just so we're clear 'yyyy/MM/yyyy' wasn't a typo?  There's no 'dd'
anywhere?
>Can you also double check that this happens in all datepickers? (try View->Go
to
Date)

Yes, and Yes, Please see attached screen shot
(Reporter)

Comment 3

13 years ago
I did some playing the the short date format on my system. Here are the results:

yyyy/MM/dd - Is formated as yyyy/MM/yyyy
yyyy/dd/MM - Is formated as yyyy/dd/yyyy
dd/MM/yyyy - Works correctly.
MM/dd/yyyy - Works correctly

So it seems like it's changeing the last part of the format to yyyy.
Summary: Date selector controls are unsable → Date selector controls get the system date format incorrectly

Updated

12 years ago
Depends on: 307895

Comment 4

12 years ago
This problem only occurs if '/' is the separator (bug 307895).  
Workaround: use '-' as the separator.
(w2k: control panel | regional options | date tab)
Status: UNCONFIRMED → NEW
No longer depends on: 307895
Ever confirmed: true

Updated

12 years ago
Depends on: 307895
(Reporter)

Comment 5

12 years ago
Tested Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051019
Mozilla Sunbird/0.2+

-> Fixed - thanks
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 6

12 years ago
*** Bug 324284 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.