E-mail Reply crash if delete last characters in message.

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: spicerun, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050707 SeaMonkey/1.0a
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050707 SeaMonkey/1.0a

Any time that I try to type an E-mail using the reply function and delete the
last characters of the message (usually removing all of the previous message in
the reply), seamonkey-1.0a crashes.
Unfortunately I can provide few details since no warning messages or anything
else comes up.



Reproducible: Always

Steps to Reproduce:
last characters of the message (usually removing all of the previous message in
the reply), seamonkey-1.0a crashes.
Unfortunately I can provide few details since no warning messages or anything
else comes up.

Reproducible: Always

Steps to Reproduce:
1. Start Seamonkey
2. Get mail, use "reply" button to reply
3. Use Backspace key or Delete key to delete any text to the last character in
the message.
4. Seamonkey-1.0a quits without any messages or notices.

Actual Results:  
Seamonkey Crashes

Expected Results:  
Text in E-mail should just be deleted, allowing typing to finish & send the message.

Running Gentoo linux, Most currently updated (Gentoo is versionless).

Pentium 4 2.8Ghz Laptop w/512Mbyte Ram.  
Direct Network connectio.
ATI IGP 340M Radeon Video Chipset.

Comment 1

13 years ago
Just curious, does this still occour with a current nightly?

Comment 2

13 years ago
(In reply to comment #1)
> Just curious, does this still occour with a current nightly?

I am seeing this very behavior, both earlier and now with:

Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.9a1) Gecko/20050830
MultiZilla/1.8.1.0h SeaMonkey/1.1a

Sometimes, it's just heavy editing which causes it, and not simply the deletion
of the last characters in an email. (By "heavy editing," I am referring to
cutting and pasting large blocks of text, using the cursor to move around
rapidly, and just very fast typing.) I usually don't see this behavior (outside
the original bug description) unless I'm really working the app...it feels like
some sort of buffer overrun (that's an impression, not a diagnosis).

Glad I found this bug, and interesting that it appears to be cross platform and
not just on OS/2.

Lewis

Comment 3

13 years ago
Can you get a talkback id for this crash? Or maybe a general stacktrace (for the
OS/2 users, i don't know if/how that is possible)?

Comment 4

13 years ago
(In reply to comment #3)
> Can you get a talkback id for this crash? Or maybe a general stacktrace (for the
> OS/2 users, i don't know if/how that is possible)?

I've uploaded a zipped process dump (and applicable kernel symbols) to my ftp
server, for use with OS/2 dump formatter:

ftp://ftp.2rosenthals.com/pub/Dumps/Bug_306427_process_dump_and_symbol_files.zip

The file is accessible via anonymous ftp.

Steps to create consistent crash:

Click Reply to reply to a message.
Edit, with several cuts.
Select a large portion of the end of the original message (above my own
signature line in the reply).
Press <Del>.
Crash.

Current PROCDUMP settings for this dump:

/PROC:MOZILLA.EXE /C:0 /P:0 /K:N /D:SUMM,PRIVATE,SHARED,INSTANCE,SYSFS,SYSSEM,SYSIO

Kernel is 14.104a_debug UNI.

Thanks for the suggestion, Frank.

Lewis

Comment 5

13 years ago
2reporter: I cannot reproduce the bug on current nightlies.
Could you please check whether the bug still persists in release version (SM 1.0)?

Comment 6

13 years ago
(In reply to comment #5)
> 2reporter: I cannot reproduce the bug on current nightlies.
> Could you please check whether the bug still persists in release version (SM
> 1.0)?
> 
(Not the reporter)

I haven't seen this in some time, but I have not tested with the 1.0 release (I'm currently using a 1.5a nightly). I'll try to check this out under 1.0 over the weekend, however.

Lewis
(Reporter)

Comment 7

13 years ago
I'm pleased to say that this bug seems to have been fixed in the official seamonkey-1.0 source code.  I have yet to see any crashes with deleting the last characters in the official Seamonkey-1.0 release I compiled.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 8

13 years ago
No specific bug / patch referenced as the fix.

-> WORKSFORME
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Updated

13 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.