flash wmode="opaque" causes odd behavior with list control and Shift/Ctrl key

RESOLVED DUPLICATE of bug 347185

Status

()

RESOLVED DUPLICATE of bug 347185
13 years ago
10 years ago

People

(Reporter: seairth, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---
Bug Flags:
blocking1.9 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

When a flash object is set to wmode="opaque", then it is not possible to select
multiple items in a list control using Ctrl or Shift keys.  In the case of Ctrl,
the entire flash object toggles between being selected and not.  The shift key
is ignored entirely.

These keys work as expected if wmode="window".

Reproducible: Always

Steps to Reproduce:




I also came across Bug 206264, which is possibly related.

Comment 1

13 years ago
This bug is also the case if wmode is set to "transparent".
I noticed this when my flash input fields didn't accept any numbers that are created with shift+key on an 'azerty-keyboard', also they don't accept ALT-GR for an '@' for instance.
an example can be found at www.taketwo.be (contact page)

Comment 2

13 years ago
(In reply to comment #1)
> This bug is also the case if wmode is set to "transparent".
> I noticed this when my flash input fields didn't accept any numbers that are
> created with shift+key on an 'azerty-keyboard', also they don't accept ALT-GR
> for an '@' for instance.
> an example can be found at www.taketwo.be (contact page)
> 

But it does work in IE btw.
This bug needs a testcase that demonstrates the bug.
Component: General → Plug-ins
Product: Firefox → Core
Version: unspecified → Trunk

Comment 5

12 years ago
bugexample:
www.taketwo.be
go to contact page. try to fill in email that includes numbers (ex. lol123@gmail.com)
make sure your keyboard is set to "azerty type" so you have to use SHIFT + key to type a number.
Normaly it won't return the right number you typed.
QA Contact: general → plugins

Comment 6

12 years ago
https://bugzilla.mozilla.org/show_bug.cgi?id=312920

This bug is similiar and has an example.  Control click should work like shift click...

MG

Comment 7

12 years ago
I confirm the bug with Firefox 2.0

It is a bug of firefox since it works as expected in IE.
Not a regression from 2.0.  -'ing.
Flags: blocking1.9? → blocking1.9-
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 347185
You need to log in before you can comment on or make changes to this bug.