When Firefox is active, using the Music Store feature of iTunes crashes iTunes

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: bliz, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20050829 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20050829 Firefox/1.6a1

When Deer Park (at least the last few weeks of nightly builds) is open, it
crashes the iTunes Music Store (and iTunes with it). When I close Deer Park, the
iTunes Music Store behaves normally again. Deer Park only crashes the Music
Store; when only viewing the library to play a stored song, etc., iTunes
operates normally--suggesting that Deer Park creates an unstable internet access
environment for iTunes when iTunes tries to go out and access the internet while
Deer Park is open.

Reproducible: Always

Steps to Reproduce:
1. Start iTunes and Deer Park (nightly build from anytime in August)
2. Once both programs are running, access the Music Store through iTunes
3. The Music Store might not crash at once, if this is the case try browsing the
internet while  browsing the Music Store.

Actual Results:  
The iTunes Music Store never loads and iTunes crashes. Deer Park appears unchanged.

Expected Results:  
A user should be able to have Deer Park open while browsing the iTunes Music
Store. Something in Deer Park is breaking iTunes' access to the internet.

Only tested using iTunes 4.9. Additional software environment info: Mac OS X
10.4.2 with latest updates (through 8.30.05), Deer Park 20050830 (though last
few weeks of nightlies break iTunes Music Store), and not surfing by proxy.

Updated

12 years ago
Summary: Firefox (Deer Park) breaks iTunes Music Store on Mac OS X 10.4 → When Firefox is active, using the Music Store feature of iTunes crashes iTunes

Comment 1

12 years ago
Works for me.
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20050929
Firefox/1.6a1
1.25GHz Powerbook G4, 512Mb RAM, OS X 10.4.2.
iTunes v5.0.1(4)

I tried various things, playing tracks in itms and qt in the browser, browsing
in both, etc - all worked.
(Reporter)

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.