Fails to re-focus additional window if link clicked again

RESOLVED DUPLICATE of bug 159946

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 159946
13 years ago
10 years ago

People

(Reporter: philipchalmers, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

Scenario:
*   Page X contains a dictionary, or Help, or some other refernece info - with
<a name="..."> for each section.
*   Page Y contains links to different sections of page X, e.g.
pageX.htm#section1, pageX.htm#section2, etc. and these links always specify a
target window name to avoid opening unlmited windows on to the same page. So
each link is <a href="pageX.htm#sectionN" target="infoWindow">

The first time the user clicks one of the links on Page Y, e.g.
pageX.htm#section1, page X appears and gets focus (comes to top).

If the user leaves page X (reference info) open, returns to page Y (content) and
clicks another link to page Y, e.g. pageX.htm#section2, it appears nothing
happens. In fact the 2nd window is open and at the new position, but under the
content window.

So from the user's point of view links of the form pageX.htm#sectionN behave
differently depending on whether page X is already open in the named window.

Reproducible: Always

Steps to Reproduce:
1. See "details"
2.
3.

Actual Results:  
See "details"

Expected Results:  
Always focus on the window whose link is clicked, even if it's already open.

If I remember correctly, even Netscape 4 managed to do this.
Could be a dup of bug 159946 but only if that's in the wrong component, as I
suspect it might be. In any case, as it notes, if we did what does seem like the
reasonable thing and did bring them to the front, we would only share that
behavior with IE 5.2 Mac.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 159946
You need to log in before you can comment on or make changes to this bug.