Do not display both "Mark as junk" and "Mark as not junk"

VERIFIED DUPLICATE of bug 273223

Status

--
enhancement
VERIFIED DUPLICATE of bug 273223
14 years ago
14 years ago

People

(Reporter: matjaz.bugzilla.2005, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050830 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050830 Firefox/1.0+

In context menu, under mark there are entries for both "as junk" and "as not
junk". There should be only one entry, depending on message junk status (as it
is true with toolbar icon).

Having both entries seems to confuse some users.

version 1.0+ (20050830)

Reproducible: Always

Steps to Reproduce:

Comment 1

14 years ago
There is a reason for this: the message can have a third state, "unclassified."
A better solution might be to disable one of the two Junk options if it doesn't 
apply to the current message(s).
Severity: minor → enhancement
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → Trunk

Comment 2

14 years ago
I guess this could be duped as bug 273223 if we use the same context menu code.
(Reporter)

Comment 3

14 years ago
Didn't know messages can be unclassified...

But this leads me to another question: how do we know which messages are
unclassified and which are marked as not junk? If we mark a message as junk, an
icon appear under junk status. There should be an icon for unclassified messages
as well.

There's probably a lot of users (me included) that didn't read the manual and
don't know about unclassified messages. Yes, I know we should read the manual,
but  still, current UI leads us to believe we only have two statuses: junk and
not junk.

Comment 4

14 years ago
(In reply to comment #3)
> But this leads me to another question: how do we know which messages are
> unclassified and which are marked as not junk? If we mark a message as junk,
> an icon appear under junk status. There should be an icon for unclassified
> messages as well.

xref bug 192153, bug 182386.
I'm pretty sure I've seen instructions on how to customize this so you *do* get 
a separate icon, altho you have to provide the icon.  There may be skins that do 
this.  Try posting a query on the newsgroups or Mozillazine.
(Reporter)

Comment 5

14 years ago
I've read comments at 182386 - most people agree with what I've previously said.
Too bad the decision was made contrary to what most people want.

Anyway, this topic has alwady been covered, so there's no use discussing it
again here, especially since we're a little away from the original subject.
(Reporter)

Comment 6

14 years ago

*** This bug has been marked as a duplicate of 273223 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

14 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.