Last Comment Bug 306614 - fieldset should not match :enabled/:disabled
: fieldset should not match :enabled/:disabled
Status: RESOLVED FIXED
: fixed1.8
Product: Core
Classification: Components
Component: CSS Parsing and Computation (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Allan Beaufour
: Hixie (not reading bugmail)
:
Mentors:
Depends on:
Blocks: 84400
  Show dependency treegraph
 
Reported: 2005-08-31 13:19 PDT by Allan Beaufour
Modified: 2007-06-05 00:13 PDT (History)
3 users (show)
bzbarsky: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (3.31 KB, patch)
2005-08-31 13:22 PDT, Allan Beaufour
bzbarsky: review+
bzbarsky: superreview+
asa: approval1.8b5+
Details | Diff | Splinter Review

Description Allan Beaufour 2005-08-31 13:19:46 PDT
HTML does not define a disabled attribute for fieldset:
http://www.w3.org/TR/html4/interact/forms.html#h-17.10
so it should not match :enabled/:disabled.
Comment 1 Allan Beaufour 2005-08-31 13:22:00 PDT
Created attachment 194464 [details] [diff] [review]
Patch

This came from bug 84400. My bad.

Testcase can be found here:
http://beaufour.dk/tmp/enabled-false.xhtml
Comment 2 Allan Beaufour 2005-09-01 09:50:17 PDT
Checked in to trunk
Comment 3 Anne (:annevk) 2005-09-08 03:14:55 PDT
Note that when we start implementing parts of Web Forms 2 which I believe is
planned on trunk we do want to support this.
Comment 4 Allan Beaufour 2005-09-27 03:32:09 PDT
Checked in to 1.8 branch

Note You need to log in before you can comment on or make changes to this bug.