frame with src=javascript:... doesn't load.

RESOLVED FIXED in mozilla1.8beta4

Status

()

Core
DOM
RESOLVED FIXED
13 years ago
11 years ago

People

(Reporter: jst, Assigned: jst)

Tracking

({regression, verified1.8})

Trunk
mozilla1.8beta4
regression, verified1.8
Points:
---
Bug Flags:
blocking1.8b4 +
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

13 years ago
After the split-window changes landed, a trivial frameset like this one doesn't
load the frame content:

<frameset rows="170,*">
<frame src="javascript:'frame1'">
<frame src="javascript:'frame2'">
</frameset>

Fix coming up.
(Assignee)

Updated

13 years ago
Status: NEW → ASSIGNED
Flags: blocking1.8b4?
Target Milestone: --- → mozilla1.8beta4
(Assignee)

Comment 1

13 years ago
Created attachment 194483 [details]
testcase
(Assignee)

Comment 2

13 years ago
Created attachment 194484 [details] [diff] [review]
Force creation of inner window when loading a javascript: URL into the window
Attachment #194484 - Flags: superreview?(bzbarsky)
Attachment #194484 - Flags: review?(mrbkap)
(Assignee)

Updated

13 years ago
Keywords: regression

Updated

13 years ago
Blocks: 305656
Comment on attachment 194484 [details] [diff] [review]
Force creation of inner window when loading a javascript: URL into the window

r=mrbkap
Attachment #194484 - Flags: review?(mrbkap) → review+
Comment on attachment 194484 [details] [diff] [review]
Force creation of inner window when loading a javascript: URL into the window

sr=bzbarsky, but I'd almost rather have an EnsureInner() method on
nsPIDOMWindow that internally gets the document and that callers can use so
they don't have to depend on GetDocument creating the inner...	Perhaps for
1.9?
Attachment #194484 - Flags: superreview?(bzbarsky) → superreview+
(Assignee)

Comment 5

13 years ago
*** Bug 305656 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

13 years ago
No longer blocks: 305656
(Assignee)

Updated

13 years ago
Attachment #194484 - Flags: approval1.8b4?
Comment on attachment 194484 [details] [diff] [review]
Force creation of inner window when loading a javascript: URL into the window

Maybe ref this bug in the comment, so we can do what bz suggested, and just cuz
it's not totally clear why GetDocument creates a new inner?

a=me anyway.

/be
Attachment #194484 - Flags: approval1.8b4? → approval1.8b4+

Updated

13 years ago
Flags: blocking1.8b4? → blocking1.8b4+
(Assignee)

Comment 7

13 years ago
Done, and fixed on the trunk and branch. Filed bug 306642 on the issue bz
brought up...
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Keywords: fixed1.8
Resolution: --- → FIXED

Updated

13 years ago
Keywords: fixed1.8 → verified1.8
(Assignee)

Updated

13 years ago
Keywords: fixed1.8

Updated

13 years ago
Keywords: fixed1.8
Added the testcase to reftest.
Flags: in-testsuite? → in-testsuite+
You need to log in before you can comment on or make changes to this bug.