can't focus on find toolbar via keyboard after visiting a site

RESOLVED DUPLICATE of bug 306686

Status

()

Toolkit
Find Toolbar
RESOLVED DUPLICATE of bug 306686
13 years ago
10 years ago

People

(Reporter: Krishna Sethuraman, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20050831 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20050831 Firefox/1.6a1

Visiting http://bugzilla.mozilla.org and tabbing around a bit, then trying / (to
start find-as-you-type) or Papillon-F pulls up Find Toolbar, but won't put
keyboard focus there.  After that, all pages display the same behavior.

Reproducible: Always

Steps to Reproduce:
0. Only noticed as of today's, maybe yesterday's nightly.  MacOSX 10.3.8.
1. Visit http://www.mozilla.org
2. Notice that Beanie-F or / (to start FAYT) will let you find as you type.  Try
this a few times and intersperse a few ESC 's to cycle through the find process.
3. Visit http://bugzilla.mozilla.org
4.  Tab through Find a bug textfield->bug number textfield->location bar->google
find bar->main html display window.
5. Start FAYT with / or Clover-F to pop up the Find toolbar.
6. Enter some characters, they'll show up in the Find toolbar.
7. Hit ESC.
8. Repeat step 5. 
9. Notice that search text no longer appears in the Find toolbar text field.
10.  Visit http://www.mozilla.org.
11.  Notice the same behavior.
Actual Results:  
No more findy.

Expected Results:  
Findy findy findy.

One can click in the Find Toolbar field with the mouse, and keyboard focus will
appear there, no problem.
(Reporter)

Comment 1

13 years ago
In step 4, if you click on the main body of the page and then use FAYT or Find, 
the behavior is normal.  However, once you tab a few times through the location 
bar and the google search bar, and back into the main page, the app loses the 
ability to focus via / or Command-F. 
(In reply to comment #0)
> 0. Only noticed as of today's, maybe yesterday's nightly.

It would be very helpful if you could install yesterday's build again and test it
so we can know the regression range for sure. Thanks.
Severity: minor → normal
Keywords: regression
I can't reproduce the problem using:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20050831 Firefox/1.6a1
(Reporter)

Comment 4

13 years ago
Testing Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) 
Gecko/20050830 Firefox/1.6a1 : 
 
Problem does not appear.  I also have tabbing set to switch focus between links 
(accessibility.tabfocus = 5); in this build, TAB tabs between links.  In the 
problem build, TAB appears to tab between just text fields (== the behavior if 
this preference was ignored, IIRC). 
Is this the same as bug 306686? i.e caused by bug 295228 (it's in the range)
(Reporter)

Comment 7

13 years ago
> Is this the same as bug 306686? i.e caused by bug 295228 (it's in the range)

My (incomplete) understanding of those bugs leads me to believe 'no', but I'm
not sure -- I only run Firefox on my Mac.  Please let me know if you can't
reproduce the problem and I'll see if I can simplify the test case.  I believe
it shows up pretty much immediately on the Mac with the 20050831 and 20050901
1.6a1 nightlies.
Bug 306686 was fixed 2005-09-02 08:54. Please test again if you can. Thanks.
(Reporter)

Comment 9

13 years ago
All good, per 20050904.  You can close this.  Thanks!
Thanks for your help with testing!

*** This bug has been marked as a duplicate of 306686 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.