In-line svg code is only shown once in the entire page

RESOLVED DUPLICATE of bug 309100

Status

()

Core
SVG
RESOLVED DUPLICATE of bug 309100
13 years ago
12 years ago

People

(Reporter: Cheong Tek Mun, Unassigned)

Tracking

1.8 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; MathPlayer 2.0; (R1 1.3))
Build Identifier: 

I am using Deer Park Alpha 2 for Mac.  In http://learnaholic.sp.edu.sg, click 
on Yes to go into main page.  In main page, there are a few in-line svg 
codes.  Only one of them is displayed.  The rest are not displayed but can be 
clicked when the mouse hover it.

Reproducible: Always

Steps to Reproduce:
1. Point the Deer Park Alpha 2 for Mac browser to http://learnaholic.sp.edu.sg
2. Click on Yes radio button
3. Only one in-line SVG is shown.  Others are not shown but can detect mouse 
hover, click etc.

Actual Results:  
Not all in-line SVG are shown.

Expected Results:  
All the in-line SVG should be shown.
It would help if the documents were valid
both generate a mismatch error

Updated

13 years ago
Component: General → SVG
Product: Firefox → Core
Version: unspecified → 1.8 Branch
(Reporter)

Comment 2

13 years ago
Created attachment 195597 [details]
Screen shot on webpage using Deer Park Alpha 2 for Windows.

The correct display of the webpage using Deer Park Alpha 2 on Windows is
attached.  
On Deer Park Alpha 2 on Mac, svg codes on the bottom frame left panel are
shown.	Those on the top frame and bottom frame right panel are not shown.
When I go to the site in the URL field, it tells me:

  "You are currently not using a Firefox with native SVG-builtin browser."

What I'm using is a current debug build of Firefox, and I can assure you that SVG is quite built in.  Please fix the broken browser-sniffing so this can actually be debugged?

(Note that there are also plenty of other browsers based on Gecko 1.8 (Seamonkey, Camino, Epiphany, etc) that will all have SVG support once they ship; you're really doing your users a disservice by blocking all those browsers).
(Reporter)

Comment 4

12 years ago
OK. I have already made it accessible using Firefox 1.5.
Please try again.
Nope, doesn't work.  Again, I'm not using Firefox 1.5.  I'm using a current debug build of what will likely be Firefox 3.0 in about a year or a year and a half.  Please make the page accessible to any Gecko user-agent with rv:1.8 or greater (so 1.8.x, 1.8.0.x, 1.9a, etc).  Firefox 1.5 is rv:1.8, as you can see from your UA string.

I'll look at this again in three weeks when I get back, I guess.
(Reporter)

Comment 6

12 years ago
This bug has been resolved in the latest Deer Park Alpha 2 browser.

*** This bug has been marked as a duplicate of 309100 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.