attachments to remote Microsoft Word passed along to OS using first word only

RESOLVED DUPLICATE of bug 221028

Status

()

Firefox
File Handling
RESOLVED DUPLICATE of bug 221028
13 years ago
13 years ago

People

(Reporter: John Wheeler, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

When using my remote access to General Electric corporate Outlook, and when
clicking on an attachment, it is always restricted to the first word when passed
along to the OS, so the OS never receives the extension, so it has no idea what
application to open the attachment with. 

Exact URLs follow:

1) attachment in the email: "Nextel Inventory Template_Modified.xls"
2) properties of that attachment:
"https://anywherela.nbcuni.com/exchange/Attach/read.asp,DanaInfo=webmail.nbc.ge.com+?obj=00000000F095805AC75BD611825700508BCFAE7E07000BA77D1BC9F5D11181FB400013044806000007CB90000000BC5FDABDDCF0EE46BF1E2F509EA0EA3E000001DFDB950000&att=ATT-0-D3D061D4DDA5774A809064DE4A0E955F-NEXTEL%7E1.XLS"
3) as passed along to OS: "Nextel"
4) response by Firefox: 
"You have chosen to open"
"Nextel"
which is a: application/octet-stream
from https://anywherela.nbcuni.com
What should Firefox do with this file?
Open with ( ) browse  <--- Firefox gets no idea that this is an .xls file
          (*) save to disk

Reproducible: Always

Steps to Reproduce:
1. obvious
2.
3.

Actual Results:  
see above

Expected Results:  
Should have converted NEXTEL%7E1.XLS to NEXTEL.XLS instead of chopping it at the
%7E1

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 221028 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.