A div with overflow:auto flickers when its display property becomes "block"

RESOLVED DUPLICATE of bug 97283

Status

()

RESOLVED DUPLICATE of bug 97283
13 years ago
13 years ago

People

(Reporter: guido, Assigned: roc)

Tracking

({css2})

1.7 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; it-IT; rv:1.7.10) Gecko/20050717 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; it-IT; rv:1.7.10) Gecko/20050717 Firefox/1.0.6

Hello,
 watch the test case. When I move the mouse on the 1st and 2nd item the div.help
gets displayed for the "div.item:hover > div.help" CSS rule, and I can move the
mouse pointer in it (even if I move the pointer out of the ).
On the 3rd item, if you move the pointer horizontally ltr the div.help shows up.
When the div.item and the div.help2 overlap, the latter flickrs.
As soon as you move the pointer out of the div.item, div.help2 does not show
anymore.

Is this correct?

Sorry for my poor english and if I've been fuzzy.

Reproducible: Always

Steps to Reproduce:
1.Open the html attachment
2 [review].Move the pointer ltr in the 1st and 2nd item, you can move the pointer into
the pop-up div
3. Move the pointer 3rd item, when the two divs overlap, the div.help2 flickers
4. When the mouse pointer exits the div.item on its right, the div.help2 disppears
Actual Results:  
div.help2 flickers and then disappears

Expected Results:  
div.help2 should behave as div.help, but providing scrollbars

Pretty similar to bug #202841
(Reporter)

Comment 1

13 years ago
Created attachment 194646 [details]
This file shows the behaviour of a div with overflow:auto
(Reporter)

Updated

13 years ago
Keywords: css2

Comment 2

13 years ago
wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.9a1) Gecko/20050901 SeaMonkey/1.1a
wfm Deerpark

confirming for Mozilla/5.0 (Windows; U; Win98; de-DE; rv:1.7.10) Gecko/20050715
Firefox/1.0.6



So Version: is 1.7 Branch, not Trunk.
Version: Trunk → 1.7 Branch

Comment 3

13 years ago

*** This bug has been marked as a duplicate of 97283 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.