Status

Tech Evangelism Graveyard
English US
P3
normal
VERIFIED WORKSFORME
19 years ago
3 years ago

People

(Reporter: info, Assigned: Blake Ross)

Tracking

Details

(URL)

(Reporter)

Description

19 years ago
mozilla  has a problem displaying the dynamic elements of the right frame.

normally, the wastebin moves from the topleft to the bottomright. (if viewed 
with netscape or ie)

Also the onMouseOver function failed.

Comment 1

19 years ago
Site relies on document.layers, document.all, and fails
to detect client correctly. See http://sites.netscape.net/ekrock/standards.html
for details on standards-compliance in Mozilla, and which proprietary features
of NS 4.x and IE will not be supported. 

Should probably mark INVALID as per
http://www.mozilla.org/newlayout/bugathon.html#layerbugs

desale, can you check and make sure that the MacroMedia animation in the right
frame fails because of non-standards compliance?
Assignee: rickg → vidur
Severity: blocker → normal
Component: HTML Element → DOM Level 0
QA Contact: petersen → desale
Summary: dhtml → [LAYER] dhtml

Updated

18 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 2

18 years ago
Had another look.  For appName="Netscape", the animation relies on
element.visibility, which is a NS 4.7-only thing.  DOM standard is
element.style.visibilty.  Marking INVALID then.

Comment 3

18 years ago
element.visibility nonstandard. INVALID verified.
Status: RESOLVED → VERIFIED
Moving all [LAYER] bugs to Evangelism component for tracking and open-source
evangelism by mozilla community members of sites that need to upgrade to support 
web standards such as HTML 4.0 (instead of LAYER/ILAYER) and the W3C DOM
(instead of Nav4 document.layers[] or IE document.all()). Sites should be
lobbied to do the upgrade using the email templates that are linked to from
http://www.mozilla.org/newlayout/bugathon.html#layerbugs . When a site's owner
has confirmed receipt of the message requesting an upgrade, the bug should be
marked with the keyword evangelized to indicate that evangelism for that bug is
complete. When the site finishes the upgrade and supports standards, the bug
should be closed.
Assignee: vidur → nobody
Status: VERIFIED → UNCONFIRMED
Component: DOM Level 0 → Evangelism
Keywords: evangwanted
QA Contact: desale → nobody
Reopening to register fact that this page probably isn't yet upgraded (until it 
is, at which point we'll close the bug). Clearing cc:s as a courtesy to reduce 
spam.
Resolution: INVALID → ---

Comment 6

18 years ago
SPAM:Changing QA contact on 111 evang bugs as I am now the new QA contact for 
this component.

Sorry about the spam

zach
QA Contact: nobody → zach

Comment 7

18 years ago
Reassigning Evangelism bugs to me, the component's new owner.  I would like to 
take this opportunity to thank nobody@mozilla.org for all of his dedication, 
contributions, and hard work, and wish him luck at his new job.  Thanks, nobody.
Assignee: nobody → BlakeR1234

Comment 8

18 years ago
Mass confirming Evangelism bugs to get off the Unconfirmed radar
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 9

18 years ago
-> evangelism@telocity.com for my evangelism bugs.

removing the now-depreciated evangelism-related keywords.

setting platform to All.
Assignee: blakeross → evangelism
Keywords: evangwanted
Hardware: PC → All

Comment 10

17 years ago
Seems like this is working right now....

Please QA/doublecheck...

Is this a Macromedia dynamic generated code?
Works for me too. Interesting code (called on load):

function YY_Mozillamat(){//v1.2
//copyright (c)2000 Yaromat.com
  if (document.getElementById&&!document.all){
     var allDIV = document.getElementsByTagName("DIV");
     for(var i=0; i<allDIV.length;i++){
       if(document.getElementById(allDIV[i].id)!=null){
                document[allDIV[i].id] =
document.getElementById(allDIV[i].id).style;
        document[allDIV[i].id].document = document;
       }
     }
  }
}
Status: NEW → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → WORKSFORME
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified
verified
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.