Last Comment Bug 306874 - Mouse selection triggered inappropriately in Deer Park (when using the JEP)
: Mouse selection triggered inappropriately in Deer Park (when using the JEP)
Status: RESOLVED FIXED
: fixed1.8
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: PowerPC Mac OS X
: -- normal (vote)
: ---
Assigned To: Josh Aas
:
: Benjamin Smedberg [:bsmedberg]
Mentors:
http://java.sun.com/applets/jdk/1.4/d...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-02 12:40 PDT by Steven Michaud [:smichaud] (Retired)
Modified: 2005-09-26 20:20 PDT (History)
5 users (show)
asa: blocking1.8b4-
asa: blocking1.8b5+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Steven Michaud [:smichaud] (Retired) 2005-09-02 12:40:32 PDT
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050902 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050902 Firefox/1.0+

In Deer Park alphas and nightlies, clicking a button inside a Java
applet can sometimes turn on mouse selection mode for the browser page
that contains the applet -- so that when you move the mouse around
outside the applet, text and graphics are selected and deselected. The
mouse behaves as if you had clicked and held the left mouse button and
were "dragging" the mouse pointer around -- even though you're not
holding down the left (or any other) mouse button.

Examples are the "Fill" and "Draw" buttons in the ArcTest JDK sample,
and the button inside the "Set animation speed" slider in the NOAA
radar looping applets:

http://java.sun.com/applets/jdk/1.4/demo/applets/ArcTest/example1.html
http://weather.noaa.gov/radar/mosaic.loop/DS.p19r0/ar.us.conus.shtml

Though at first sight you'd think that this was a Deer Park bug, it
actually seems to be caused by one or more Apple bugs of long
standing. (These Apple bugs also have other symptoms, and the mouse
selection problem seems only to have been triggered by recent changes
on the Mozilla.org "trunk".)

I'm about to release a Java Embedding Plugin "nightly" (version
0.9.3+c) that works around these Apple bugs. I hope to get it quickly
landed on the trunk and (especially) the 1.8 branch, so that it will
be included in Firefox 1.5 Beta 1 when that comes out next week.

This same bug has also been filed at the Java Embedding Plugin's Bugs
"tracker":

http://sourceforge.net/tracker/index.php?func=detail&aid=1280927&group_id=107955&atid=649116



Reproducible: Always
Comment 2 Simon Fraser 2005-09-02 14:09:31 PDT
I think this is a dup (though the target bug may have been marked fixed).
Comment 3 Josh Aas 2005-09-02 14:12:57 PDT
I'd like to see this fixed, but I recommend not blocking on it.
Comment 4 Steven Michaud [:smichaud] (Retired) 2005-09-02 14:35:35 PDT
> Steven, note also your bug 1280969:

I've responded to your report at the JEP's Bugs tracker.  I wasn't able to
reproduce the problem.  Has anyone else here seen it?  (If so, best to respond
at the JEP's Bugs tracker.)

Comment 5 Steven Michaud [:smichaud] (Retired) 2005-09-02 14:45:27 PDT
I've just released JEP 0.9.3+c:

http://javaplugin.sourceforge.net/

Please test it before deciding whether or not to land it on the 1.8 branch
before Firefox 1.5 Beta 1 is released.

I do realize that it's risky to make non-trivial changes so close to the
release date.  But I've tested JEP 0.9.3+c quite thoroughly.  And the problems
that it fixes are rather nasty.

Comment 6 Steven Michaud [:smichaud] (Retired) 2005-09-02 17:03:44 PDT
> I think this is a dup (though the target bug may have been marked fixed).

I can't find anything.  Do you remember anything more about the bug of which
this one (bug 306874) might be a dup?

Comment 7 Simon Fraser 2005-09-02 20:57:45 PDT
I recall a bug about the mouse getting "stuck" down when you clicked on a
QuickTime VR movie, then released and moused over the page.
Comment 8 Steven Michaud [:smichaud] (Retired) 2005-09-03 08:17:43 PDT
> I recall a bug about the mouse getting "stuck" down when you clicked on a
> QuickTime VR movie, then released and moused over the page.

Still can't find anything, even using a very broad search ("QuickTime" and
"mouse" in any comment, limited to the Macintosh platform).

In any case, I doubt that this exact problem could be reproduced with any
other plugin -- I'm pretty sure it's caused by a bug (or bugs) in the
Cocoa-Carbon interface, and I doubt that any other plugin (besides the JEP)
uses it.
Comment 9 Asa Dotzler [:asa] 2005-09-06 11:50:16 PDT
we want to get this on the trunk and then we'll consider it for beta2 if all
looks well.
Comment 10 Josh Aas 2005-09-07 18:11:15 PDT
updated JEP that should fix this was landed on the trunk. leaving this bug open
for a branch landing if that works out.
Comment 11 Steven Michaud [:smichaud] (Retired) 2005-09-16 15:55:57 PDT
The fix for this is now incorporated in version 0.9.4 of the Java Embedding
Plugin, which I've just released:

http://javaplugin.sourceforge.net/

Comment 12 Asa Dotzler [:asa] 2005-09-22 12:07:55 PDT
->josh
Comment 13 Josh Aas 2005-09-26 16:32:32 PDT
JEP 0.9.4+a landed on branch and trunk.
Comment 14 Samuel Sidler (old account; do not CC) 2005-09-26 20:20:59 PDT
Fixed on branch per comment 13.

Note You need to log in before you can comment on or make changes to this bug.