toolbar customization window in background disables menu functionality

RESOLVED WONTFIX

Status

()

--
major
RESOLVED WONTFIX
13 years ago
6 years ago

People

(Reporter: asituationist, Unassigned)

Tracking

1.5.0.x Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
Placing the toolbar customization window in the background behind a browser
window disables sub-menu functionality in all menus with the exception of the
Deer Park menu.
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050902
Firefox/1.0+ OS X 10.4.2

Steps to reproduce:
1. Have a browser window open.
2. Control-click/right-click on toolbar + select 'Customize...'.
3. Click into browser window.
4. Sub-menu options, with the exception of 'Deer Park', are disabled.

What should happen:

Sub-menu items should be available instead of necessitating the user to either
close or move the browser window to access the customization window.

Comment 1

13 years ago
What it seems like here is that we should be opening the customize window as a
sheet on Mac, rather than a window. That way we can follow the HIG and be like
other Mac apps and there's no way for the user to loose the customize window
behind the browser. 

Can someone on another OS see if this is mac only?

Comment 2

13 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050902 Firefox/1.0+
Ubuntu Linux 5.04 (Hoary)

On Linux, the toolbar customization window can't go behind the window that was
used to open it and the menubar (File, Edit, View, etc.) is disabled while it is
open.

However, if you have two browser windows open, then you open the toolbar
customization window in one browser window, then in the other browser window,
the menubar of the second window becomes disabled and unusable.  The issue on OS
X sounds similar, but I'm not sure if the problem on Linux is the same.
(In reply to comment #1)
> What it seems like here is that we should be opening the customize window as a
> sheet on Mac, rather than a window.

Unfortunately, there is no easy way to do this.  To make it into a sheet would
make it descend just below the title bar, obscuring the toolbar.  The best fix
may be to just make it modal, but I don't know if that would impact moving
things to and from the toolbar.

Comment 4

13 years ago
(In reply to comment #1)
> What it seems like here is that we should be opening the customize window as a
> sheet on Mac, rather than a window. That way we can follow the HIG and be like
> other Mac apps and there's no way for the user to loose the customize window
> behind the browser. 

bug 206649

Comment 5

13 years ago
Confirming, I see this with 
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050903
Firefox/1.0+

Manage Bookmarks and AdBlock Prefs menus can be put in the background and leave
the top toolbar menu available (Deer Park, Edit, View, Go ...).

Of those I checked, the problem's only when the Toolbar customization (that's
/View/Toolbars/Customize) is in the background, the main top toolbar choices are
grayed out except the first one "Deer Park" 
The current behavior was "by design" when this dialog was a sheet everywhere.
Later, the sheet has been turned into a dialog, but the hack which disables the
browser menus wasn't remvoed.

The other issue is the leak of support for dependent windows in widget:mac -
it's harder (but possible!) to access the parent browser window on windows/linux.
OS: MacOS X → All
Hardware: Macintosh → All

Comment 7

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050904
Firefox/1.0+

In Win XP, the toolbar customization window can't go behind the window that was
used to open it and the menubar is disabled while it is open.

Also don't see the problem with two browser windows raised in Comment #2.  With
two windows open, if you open open the toolbar customization window in one
browser window, the menubar on the other browser window remains active and usable.

Comment 8

13 years ago
When I click 'done' of the tool bar 'customize...', the menu bar remains disabled. I have to exit/close firefox to enable the menu bar again. Is there a fix??


(In reply to comment #7)
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050904
> Firefox/1.0+
> 
> In Win XP, the toolbar customization window can't go behind the window that was
> used to open it and the menubar is disabled while it is open.

Comment 9

13 years ago
i270666 tells more on this. hasn't it been there for long?
To be superseded by bug 770135
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.