Closed Bug 306943 Opened 15 years ago Closed 15 years ago

URL with backslash instead of antislash fails

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 64488

People

(Reporter: s.celles, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.7.10) Gecko/20050717 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.7.10) Gecko/20050717 Firefox/1.0.6

Hello,

I write you because I think Mozilla should resolve URL with backslash instead of
antislash.

For example in the page 
http://formation.paysdelaloire.iufm.fr/ressources/plp/maths_sciences/LE%20CHAMP%20MAGNETIQUE.htm

The webmaster had the bad idea of using MS Word for creating a web page.

Word is know to badly export as HTML

URL contains antislash (\) and slash(/) instead of just slash(/)

for example

http://formation.paysdelaloire.iufm.fr/ressources/plp/maths_sciences/animation_explorer\theoreme_ampere.htm

instead of

http://formation.paysdelaloire.iufm.fr/ressources/plp/maths_sciences/animation_explorer/theoreme_ampere.htm

I know that that's a very bad thing but many personal site are made like this so
Mozilla browser should accept such an URL (a good idea should be to show a
picture at bottom right of the FireFox windows showing that the page is not
valid because of the antislash error)

but the page should appear...


Reagards

Reproducible: Always
Sorry, a backslash in an URL is invalid. Internet Exploder handles this incorrectly.

*** This bug has been marked as a duplicate of 64488 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.