Closed Bug 306963 Opened 16 years ago Closed 16 years ago

autocomplete hang when LDAP server not available

Categories

(Thunderbird :: Message Compose Window, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 79509

People

(Reporter: rmeden, Assigned: mscott)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6 (ax) Mnenhy/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6 (ax) Mnenhy/0.7

I am configured to use a LDAP server internal to my company's network.  If the
LDAP server is not available (or I'm not in the office and the VPN is not up),
TB hangs for about 15 seconds on EACH TO: entry for the autocomplete to try the
LDAP server.  This is *very* annoying.  (I tend to connect the VPN just to avoid it)

Suggested fixes:

1. Don't block on the LDAP connect.  I think this is what OE does.
2. Cache a LDAP failure.  If it fails, don't try again on the next address in
the same message or for a certain amount of time.
3. Allow a configurable LDAP timeout.

I'm surprised this isn't a known bug.... I did search for it, Honest!





Reproducible: Always

Steps to Reproduce:
1. Ensure TB is configured to use LDAP and the server is not available.
2. Compose new message
3. Start typing in the TO: field
bug 90815 -> bug 79509

*** This bug has been marked as a duplicate of 79509 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.