Large jpegs corrupt display

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: Thomas Swan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6 (ax)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6 (ax)

Any image from http://alt.ngs.noaa.gov/katrina/KATRINA0000.HTM breaks Firefox. 
The initial scaled image display works.  Zooming the image paints the first row
of pixels all the way down the screen.  Then shrinking the image again displays
bit trash all over the image canvas.

Reproducible: Always

Steps to Reproduce:
1. Load the image in the URL
2. Click on the image to resize
3. Image displays incorrectly (IE does it right)
4. Click on the image again to shrink
5. Image contains trash.

Actual Results:  
Image is corrupted

Expected Results:  
Image should display in both large and shrunken formats

Comment 1

12 years ago
Seems to be WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4)
Gecko/20050831 Firefox/1.0+

Comment 2

12 years ago
WFM - Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050902
Firefox/1.0+

Comment 3

12 years ago
WFM - Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20050902
Firefox/1.6a1 ID:2005090216
(Reporter)

Comment 4

12 years ago
Can any of you confirm this in 1.0.6?

Comment 5

12 years ago
This WFM in 1.0.6. Please reopen if you can reproduce with a clean profile in
the latest builds.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
I see this in the latest branch nightly on Windows XP as well.

Reproducing is easy for me. Simply open the image and wait for it to finish
loading and you'll notice small amounts of corruption at the bottom of it (image
to be attached). If you zoom in, you'll notice you're not actually zoomed in and
will see that it's just random colors in straight lines... yay. Finally if you
zoom back out, it gets completely corrupted (image to be attached).

For what it's worth, it eventually showed fine and I had to restart FF to get
the problem to re-occur, but switching tabs after it's been fully loaded
normally causes it to happen more often.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Created attachment 194862 [details]
Minor corruption on first load
Created attachment 194863 [details]
Major corruption

This occurs either after zooming in and back out or after switching tabs after
the image has been fully loaded.

Reproducable ~8/10 times.

Using the following build with a clean profile: Mozilla/5.0 (Windows; U;
Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050904 Firefox/1.0+
(Reporter)

Comment 9

12 years ago
Created attachment 194937 [details]
Corruption on Zoom (latest-trunk)

Showing corruption on zoom (using latest-trunk)
(Reporter)

Comment 10

12 years ago
I can always reproduce in Firefox 1.0.6 and trunk, but I cannot reproduce in
Mozilla 1.7.11.  It seems Firefox specific.
(Reporter)

Comment 11

12 years ago
Some corruption seems to happen on repaint operations as well.  Switching from
tabs as noted above gives different trash patterns, full-zize and shrunk.

Comment 12

12 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050909
Firefox/1.4 ID:2005090906

Comment 13

12 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

please reopen if you can recreate this with FF 1.5 or trunk.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.