crash if select "back" item from context menu. normal back button works.

RESOLVED WORKSFORME

Status

()

Core
SVG
--
critical
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: lkorts+bugzilla, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20050903 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20050903 Firefox/1.6a1

this is a tutorial file from inkscape-0.41-5 package under debian (sid/unstable)
file is located under /usr/share/inkscape/tutorials/making_markers.svg
i just copied it to my homepage.

Reproducible: Always

Steps to Reproduce:
1. go to some web page
2. enter click on link or enter address to svg file
3. select back from context menu

Actual Results:  
immediate crash.


Expected Results:  
returning to previous page:)
or at least warning message in case of unparseable/non-conformable svg file
(Reporter)

Comment 1

13 years ago
Created attachment 194784 [details]
offending svg file

Comment 2

13 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20050903 Firefox/1.6a1
ID:2005090314

I can't get a useful stack from this. All I get is: 

The program 'Gecko' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadValue (integer parameter out of range for operation)'.
  (Details: serial 66567 error_code 2 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
This worksforme with a current trunk build...

Comment 4

12 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20051207 Firefox/1.6a1

Same here. Just for good measure, I went back and tested it in a build from 2005-08-21 and I got the same error I posted in comment 2. I really don't feel like tracking down a range to see when this got fixed, but if you're up for this, feel free to reopen and dupe, or mark as FIXED.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.