Installer gives error 1010 in 1.8 branch localized nightly

RESOLVED FIXED

Status

()

Firefox
Build Config
--
critical
RESOLVED FIXED
13 years ago
7 years ago

People

(Reporter: Klaus P. Kuhlemann, Assigned: Benjamin Smedberg)

Tracking

({fixed1.8})

1.5.0.x Branch
x86
Windows 98
fixed1.8
Points:
---
Bug Flags:
blocking1.8b5 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b4) Gecko/20050903 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Win98; de-DE; rv:1.8b4) Gecko/20050903 Firefox/1.0+

Trying to install the 20050903 de-DE mozilla1.8 brunch nightly, the installer
fails with error 1010 - unable to install german language file. Same with
20050902 build. 

Reproducible: Always

Steps to Reproduce:
1.Download latest 1.0+ de-DE brunch installer build.
2.Try to install (custom, changed directory, with reporter and talkback).
3.

Actual Results:  
Installer fails to install, terminates with errror 1010. Installed firefox.exe
dont work.

Expected Results:  
Installing of a usable german program.

Same thing installing without profile in an empty directory.
(Reporter)

Updated

13 years ago
OS: other → Windows 98
Version: unspecified → 1.5 Branch
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050904
Firefox/1.6a1 ID:2005090421

No error installing 1.8b4_2005090417 in German on WinXP. 
(Reporter)

Comment 2

13 years ago
Same issue on Win98SE with 2005090417 de build. I copied the de.xpi out of the
windows temp folder while installer was running. Extracting the files with 7zip
and installing them manually, I got a working german installation, but without
any registry keys because of the early stop of the installer.
Trying to install the de.xpi into an en-US build as an extension gave
"unexpected error 1010" again. Manual install of the files changed language
properly.
Thats an error of the install script of the delonicera@walla.com.xpi file.  
(Reporter)

Comment 3

13 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b4)
Gecko/20050903 Firefox/1.0+
> Build Identifier: Mozilla/5.0 (Windows; U; Win98; de-DE; rv:1.8b4)
Gecko/20050903 Firefox/1.0+
> 
> Trying to install the 20050903 de-DE mozilla1.8 brunch nightly, the installer
> fails with error 1010 - unable to install german language file. Same with
> 20050902 build. 
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1.Download latest 1.0+ de-DE brunch installer build.
> 2.Try to install (custom, changed directory, with reporter and talkback).
> 3.
> 
> Actual Results:  
> Installer fails to install, terminates with errror 1010. Installed firefox.exe
> dont work.
> 
> Expected Results:  
> Installing of a usable german program.
> 
> Same thing installing without profile in an empty directory.

(In reply to comment #2)
> Same issue on Win98SE with 2005090417 de build. I copied the de.xpi out of the
> windows temp folder while installer was running. Extracting the files with 7zip
> and installing them manually, I got a working german installation, but without
> any registry keys because of the early stop of the installer.
> Trying to install the de.xpi into an en-US build as an extension gave
> "unexpected error 1010" again. Manual install of the files changed language
> properly.
> Thats an error of the install script of the de.xpi file.  

Summary: Installer gives error 1010 in 1.8 brunch de-DE nightly → Installer gives error 1010 in 1.8 branch de-DE nightly
Exactly the same problem with Polish (pl) 1.8 branch builds...
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Installer gives error 1010 in 1.8 branch de-DE nightly → Installer gives error 1010 in 1.8 branch localized nightly
...but the same build (Sept. 08, pl 1.8 branch build) installs OK under Windows
2000 Server.

As MMx suggested on IRC, this may be specific to non-NT Windows.
Flags: blocking1.8b5?

Comment 6

13 years ago
when did this regress?
Flags: blocking1.8b5? → blocking1.8b5+

Comment 7

13 years ago
Here's my install_wizard.log on winME, maybe this can help us to find out what's
wrong.

** is_winnt value: true <- is this wrong?
** ERROR (-202): Windows Shortcut: \Mozilla Firefox <- shortcut problem?

The complete log:

     ** initInstall: platformNode=undefined
     zh-TW Langpack (version 1.4)
     --------------

     ** initInstall: 0
     ** fProgram: C:\Program Files\Mozilla Firefox\
     ** addDirectory() returned: 0
     ** fTarget: C:\Program Files\Mozilla Firefox\defaults\
     ** addDirectory() returned: 0
     ** fTarget: C:\Program Files\Mozilla Firefox\searchplugins\
     ** addDirectory() returned: 0
     ** winreg.isKeyWritable(): function
     ** restrictedAccess value: false
     ** szCurrentVersion: null
     ** szCurrentVersion: null
     ** szCurrentVersion: null
     ** is_winnt value: true
     ** folderQuickLaunchExists: true
     ** Folder StartMenuPrograms: null
     ** Folder StartMenu        : null
     ** Folder FolderDesktop    : C:\WINDOWS\All Users\Desktop
     ** Folder FolderQuickLaunch: C:\WINDOWS\Application Data\Microsoft\Internet
Explorer\Quick Launch
     ** fileExe                 : C:\Program Files\Mozilla Firefox\firefox.exe
     ** fFolderPrograms         : null
     ** scExeDesc               : Mozilla Firefox
     ** fProgram                : C:\Program Files\Mozilla Firefox\
     ** ERROR (-202): Windows Shortcut: \Mozilla Firefox
     ** ERROR (-202): Windows Shortcut: \Mozilla Firefox (Safe Mode)
     ** szCurrentMozillaVersion: null
     ** szCurrentMozillaVersion: null
     [1/117]	Installing: C:\Program Files\Mozilla Firefox\browserconfig.properties
     [2/117]	Installing: C:\Program Files\Mozilla Firefox\chrome\chromelist.txt
     [3/117]	Installing: C:\Program Files\Mozilla
Firefox\defaults\profile\mimeTypes.rdf
     [4/117]	Installing: C:\Program Files\Mozilla
Firefox\defaults\profile\search.rdf
     [5/117]	Installing: C:\Program Files\Mozilla
Firefox\defaults\pref\firefox-l10n.js
     [6/117]	Installing: C:\Program Files\Mozilla Firefox\chrome\zh-TW.manifest
     [7/117]	Installing: C:\Program Files\Mozilla Firefox\searchplugins\googletw.gif
     [8/117]	Installing: C:\Program Files\Mozilla
Firefox\defaults\profile\chrome\userContent-example.css
     [9/117]	Installing: C:\Program Files\Mozilla
Firefox\searchplugins\creativecommons.src
     [10/117]	Installing: C:\Program Files\Mozilla
Firefox\defaults\profile\bookmarks.html
     [11/117]	Installing: C:\Program Files\Mozilla Firefox\updater.ini
     [12/117]	Installing: C:\Program Files\Mozilla Firefox\searchplugins\ebaytw.gif
     [13/117]	Replacing: C:\Program Files\Mozilla Firefox\README.txt
     [14/117]	Installing: C:\Program Files\Mozilla
Firefox\searchplugins\amazondotcom.src
     [15/117]	Installing: C:\Program Files\Mozilla
Firefox\defaults\profile\chrome\userChrome-example.css
     [16/117]	Installing: C:\Program Files\Mozilla Firefox\chrome\zh-TW.jar
     [17/117]	Installing: C:\Program Files\Mozilla
Firefox\searchplugins\creativecommons.png
     [18/117]	Installing: C:\Program Files\Mozilla
Firefox\searchplugins\googletw.src
     [19/117]	Installing: C:\Program Files\Mozilla
Firefox\defaults\profile\localstore.rdf
     [20/117]	Installing: C:\Program Files\Mozilla Firefox\searchplugins\ebaytw.src
     [21/117]	Installing: C:\Program Files\Mozilla
Firefox\searchplugins\amazondotcom.png
     [22/117]	Replacing: C:\Program Files\Mozilla
Firefox\defaults\profile\mimeTypes.rdf
     [23/117]	Replacing: C:\Program Files\Mozilla
Firefox\defaults\profile\search.rdf
     [24/117]	Replacing: C:\Program Files\Mozilla
Firefox\defaults\pref\firefox-l10n.js
     [25/117]	Replacing: C:\Program Files\Mozilla
Firefox\defaults\profile\chrome\userContent-example.css
     [26/117]	Replacing: C:\Program Files\Mozilla
Firefox\defaults\profile\bookmarks.html
     [27/117]	Replacing: C:\Program Files\Mozilla
Firefox\defaults\profile\chrome\userChrome-example.css
     [28/117]	Replacing: C:\Program Files\Mozilla
Firefox\defaults\profile\localstore.rdf
     [29/117]	Replacing: C:\Program Files\Mozilla Firefox\searchplugins\googletw.gif
     [30/117]	Replacing: C:\Program Files\Mozilla
Firefox\searchplugins\creativecommons.src
     [31/117]	Replacing: C:\Program Files\Mozilla Firefox\searchplugins\ebaytw.gif
     [32/117]	Replacing: C:\Program Files\Mozilla
Firefox\searchplugins\amazondotcom.src
     [33/117]	Replacing: C:\Program Files\Mozilla
Firefox\searchplugins\creativecommons.png
     [34/117]	Replacing: C:\Program Files\Mozilla Firefox\searchplugins\googletw.src
     [35/117]	Replacing: C:\Program Files\Mozilla Firefox\searchplugins\ebaytw.src
     [36/117]	Replacing: C:\Program Files\Mozilla
Firefox\searchplugins\amazondotcom.png
     [37/117]	Create Registry Key: HKEY_LOCAL_MACHINE\SOFTWARE\Mozilla []
     [38/117]	Create Registry Key: HKEY_LOCAL_MACHINE\SOFTWARE\Mozilla\Mozilla
Firefox []
     [39/117]	Store Registry Value String:
HKEY_LOCAL_MACHINE\SOFTWARE\Mozilla\Mozilla Firefox [CurrentVersion]
     [40/117]	Create Registry Key: HKEY_LOCAL_MACHINE\SOFTWARE\Mozilla\Mozilla
Firefox\ []
     [41/117]	Create Registry Key: HKEY_LOCAL_MACHINE\SOFTWARE\Mozilla\Mozilla
Firefox\\Main []
     ** performInstall() returned: 1010

     Install **FAILED** with error 1010  --  2005-09-19 11:35:36

Comment 8

13 years ago
Created attachment 196615 [details]
en-US install_wizard.log

The (succesfull) install log of en-US.xpi

Comment 9

13 years ago
(In reply to comment #7)
> ** is_winnt value: true <- is this wrong?

Looks wrong to me. :)

>      ** Folder StartMenuPrograms: null
>      ** Folder StartMenu        : null

Probably the reason for failing to install the shortcuts (and may be caused by
the winnt check earlier), however, that is not why it dies, I don't think.

>      ** szCurrentMozillaVersion: null
>      ** szCurrentMozillaVersion: null

I don't know if these represent the currently-installed version, or about to be
installed version (if the latter, they are very bad).

>      [41/117]	Create Registry Key: HKEY_LOCAL_MACHINE\SOFTWARE\Mozilla\Mozilla
> Firefox\\Main []

This is the fatal point - it is missing the key name between the "Mozilla
Firefox" and "Main" keys. My Registry has two keys at this point, "1.0.6
(en-US)" and "1.4 (en-US)", so I'd guess that you should be seeing something
like "1.4 (zh-TW)" at this point.

Comment 10

13 years ago
Created attachment 196616 [details]
Localized langpack install log on Windows ME

The previous log attached in comment is too long... sorry,
Please use this one instead.

Comment 11

13 years ago
After being compared to en-US (succesful) install_wizard.log (see attachment):

 ** fFolderPrograms         : null 
  (in en-US this was C:\WINDOWS\Start Menu\Programs\Mozilla Firefox)
 That's why shortcuts were not created (** ERROR (-202): Windows Shortcut:
\Mozilla Firefox)

 ** szCurrentMozillaVersion: null
 That's because previous install log was made on a ME without any Mozilla product
 installed. And after succesfully installed en-US, the value changed to 1.7.5 even
 on a localized installer, so it's OK.

 ** [41/112]	Create Registry Key: HKEY_LOCAL_MACHINE\SOFTWARE\Mozilla\Mozilla
Firefox\\Main []
 This should be the root cause. Localized names did not appear in registry names.

Comment 12

13 years ago
->axel
Assignee: nobody → axel

Comment 13

13 years ago
I suspect that this is a fall out from bug 297813, but I have no idea
why localized installers wouldn't have a $UserAgent$ defined.

http://lxr.mozilla.org/mozilla/source/browser/installer/windows/ab-CD.jst#39
looks like the sweet spot, Benjamin, any idea?

(Not sure if I can really take this, but I'll see how far I can go.)
Assignee: axel → l10n

Comment 14

13 years ago
From the limited testing and investigating that I can do from here, it looks
like en-US calls into makeall.pl to set the UserAgent, but locales do not.
Looking at
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla1.8/1127507460.18967.gz&fulltext=1
makeall is called from deliver.pl, neither is called on 
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla1.8-l10n-pl/1127488620.30823.gz&fulltext=1
(pl windows 1.5 release repackaging)
deliver.pl is only called from build_static.pl, it seems, asking lxr and
restricting this to toolkit results.

Sorry, back to nobody, maybe Chase can pick this up, or we have to wait for
Benjamin. I don't know how to reliably reverse engineer this further.
Assignee: l10n → nobody
(Assignee)

Comment 15

13 years ago
Created attachment 197344 [details] [diff] [review]
Set the useragent in parseandmakejs.pl

This is untested, but should do it. I'll do a set of windows builds tomorrow to
verify that it works as I think it should.
Attachment #197344 - Flags: review?(chase)
(Assignee)

Updated

13 years ago
Assignee: nobody → benjamin
Component: Installer → Build Config
(Assignee)

Updated

13 years ago
Whiteboard: has patch, needs review (Chase)

Comment 16

13 years ago
Comment on attachment 197344 [details] [diff] [review]
Set the useragent in parseandmakejs.pl

I really wonder if this stuff should be refactored, but that should surely be
done on the trunk, not on branches.
Attachment #197344 - Flags: review?(chase) → review+
(Assignee)

Comment 17

13 years ago
Fixed on trunk.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Assignee)

Updated

13 years ago
Attachment #197344 - Flags: approval1.8b5?

Updated

13 years ago
Attachment #197344 - Flags: approval1.8b5? → approval1.8b5+
(Assignee)

Comment 18

13 years ago
Fixed on 1.8 branch
Keywords: fixed1.8
Whiteboard: has patch, needs review (Chase)
You need to log in before you can comment on or make changes to this bug.