Ordered lists not displaying bullet numbering when list items are long

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: dpashute, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.10) Gecko/20050717 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.10) Gecko/20050717 Firefox/1.0.6

We auto generate a list of files as part of our update/commit process. The
hyperlinks are broken up such that you can click on any part of the file or path
and it will either open that folder or show the path but due to our [ perhaps
somewhat unconventional ;) ] - file naming method these list items can end up
being quite large.

It would seem that when the file names are sufficiently long (i.e. ones
particularly far down the directory structure) and cause our hyperlink generator
to create a list item beyond a certain length, the number for that (ordered)
list item does not appear.

Will attach a .png showing the Firefox display and the source HTML. In this
particlar example, the fourth list item does not have a bullet number.

(Have searched for existing cases of this bug but not able to find anything).

Reproducible: Always

Steps to Reproduce:
1.Will attach example HTML
2.
3.

Actual Results:  
Missing bullet number (see attachments)

Expected Results:  
Displayed the number 4 at the start of the line.
(Reporter)

Comment 1

13 years ago
Created attachment 194842 [details]
HTML source showing problem
(Reporter)

Comment 2

13 years ago
Created attachment 194843 [details]
Image showing Firefox window and mising bullet number
WFM

Comment 4

13 years ago
WFM - Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050903
Firefox/1.0+
(Reporter)

Comment 5

13 years ago
Are you guys both running newer versions that me? Could this be something that
might have already been fixed somehow since 1.06?

Comment 6

13 years ago
Yes, there is a good chance that it has been fixed since the the 1.0 codebase
was locked a year ago.

If you want to try for your self try one of the zip builds from
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla1.8/
makeing a new profile for the test is recommended.
http://kb.mozillazine.org/Profile_manager#Command_line

Comment 7

13 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20050903 Firefox/1.6a1

Works for me, too. This is definitely fixed in 1.5.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

13 years ago
Thanks, I appreciate the links, but to be honest I'll probably wait until the
1.5 beta release in a few days time before checking again - cheers! :)
You need to log in before you can comment on or make changes to this bug.