Folders in Personal Toolbar not redrawn on resize

RESOLVED DUPLICATE of bug 305706

Status

SeaMonkey
Bookmarks & History
RESOLVED DUPLICATE of bug 305706
13 years ago
13 years ago

People

(Reporter: Hermann Schwab, Assigned: Pierre Chanial)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.9a1) Gecko/20050903 SeaMonkey/1.1a
screen resolution 800x600

I've got oodles of folders in my PT, and some more in the overflow. When I
shrink the browser width folders are going into the overflow, when I grow the
width folders gone to the overflow are getting visible again.
When I manually shrink to about 50% and then use the windows icon to resize
between full size and 50%, often the folders gone to the overflow are staying
there, coming again only when I open a new window, but still missing in the old
window.

Steps to repeat:
1. have a PT with lots of folders, I got about 25, 19 thereof visible.
2. shrink width to about 50 percent
3. use windows button restore/maximize to repeatedly change the width between
reduced and full size.
4. observe that often no folders are shown in the newly gained space, only the
chevron >> to the right.
5. When the folders are missing I can't get them back by switching tabs, reload,
loading another URL, sending Browser to tray and restore.

I also observed about half a second delay between restoring the PT and
populating the newly gained space with folders.
I assume the delay may be caused by the huge bookmarks file, 4MB, the 16 MB
history, and a slow celeron 333 with 128 MB RAM.

*** This bug has been marked as a duplicate of 305706 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.