If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Attach file causes a hang

RESOLVED WORKSFORME

Status

Thunderbird
Message Compose Window
--
critical
RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: Pierre Ossman, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b3) Gecko/20050827 Fedora/1.1-0.2.8.deerpark.alpha2 Firefox/1.0+
Build Identifier: version 1.0.6-5 (20050818)

I have an intermittent problem of Thunderbird hanging when clicking attach in
the compose window. It stops with the button rendered as depressed but no browse
window shows up. At this point I have to kill the process. Dragging files always
works though.

The problem is not 100% reproducible. It seems (I haven't verified this) that
the chance of it hanging increases the longer I have it running.

Reproducible: Sometimes

Steps to Reproduce:

Comment 1

12 years ago
Related to bug 280491, bug 275015 or bug 295674?
(Reporter)

Comment 2

12 years ago
This is on Linux, so it's not identical. Also, the problem is intermittent here,
which doesn't seem to be the case in the other bugs.

Comment 3

12 years ago
(In reply to comment #2)
> This is on Linux, so it's not identical. Also, the problem is intermittent
> here,
> which doesn't seem to be the case in the other bugs.

I thought that I would comment that I am having the identical issue on XPSP1, and Thunderbird 1.0.7/1.5 RC1. Button stays depressed, and Thunderbird compose window loses focus, then no dialog box. Nothing new has changed here on the system.. I apoligize. I tried to change it to XP, and it wouldn't let me. :|

Comment 4

12 years ago
When you enter a direction (example: C:\xampp\) to attach a file Thunderbird crashes.
(Reporter)

Comment 5

12 years ago
I'm no longer seeing this problem, so if it's ok for everyone else then feel free to close the bug.

Comment 6

12 years ago
(In reply to comment #5)
> I'm no longer seeing this problem, so if it's ok for everyone else then feel
> free to close the bug.

The bug is still alive and well. I just reinstalled Windows XP on a Toshiba Laptop, and all of the windows updates, and then installed thunderbird. Still there, as vibrant as before.

Comment 7

12 years ago
there's a bug where I attached a proposed fix for a bug like this, but I don't know that it ever got reviewed...I'll go look.

Comment 8

12 years ago
I am also seeing this bug on Tbird (version 1.5 (20051201), Mac OS X. Tried rebooting, thinking it was a Finder or filesystem issue, but bug immediately reproduced itself next time I tried clicking on "Attach" icon.

Steps to reproduce
1. open tbird
2. Click "compose" in toolbar
3. Click "attach" in message compose toolbar

At this point Tbird hangs showing colored spinning beach ball..

Comment 9

11 years ago
I figured out what is causing this. If "user_pref("mail.compose.attach.dir", "path\\to\\files");" is set to something invalid in prefs.js, then the attach button will hang. When I recently reinstalled, I found this parameter pointing to an old, and now invalid network share. I've since updated that to reflect C:\\Documents and Settings\\%username%\\desktop, and it now the attach works fine. In the above example, %%username% was replaced with the actual username. Please let me know if I can provide any additional detail.

Thanks,
John
QA Contact: message-compose
closing WFM per reporter comment 5.

Eugene, if you still see the problem in version 2 and don't find an open bug please flle a new bug.

David, what if anything should be done about comment 9?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
Version: unspecified → 1.0

Comment 11

10 years ago
#c7 is still relevant - but I don't know what bug that was attached to. I don't see a pending review request that seems relevant, so either my review request was cancelled, or maybe approved - I just don't remember. The change was in the toolkit code, not mailnews code, iirc.

Comment 12

10 years ago
Please also see <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=307106#c9">comment #9.</a> There obviously should be a check/redirect in the code on a default path. It shouldn't hang the application with the path invalid. I just wanted to comment as I saw that this had been resolved. By changing this to an invalid path on linux, xp, and macosx, I've been able to reproduce this non-attachable condition.

Thanks.
I missed comment 7 :(

David, is bug 240644 patch attachment 189098 [details] [diff] [review] what you are thinking of

Comment 14

10 years ago
thx, that's the one. Now I have to figure out who's the module owner for that code...
You need to log in before you can comment on or make changes to this bug.