If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

svg dom java bindings unsupported

RESOLVED WONTFIX

Status

()

Core
SVG
RESOLVED WONTFIX
12 years ago
10 years ago

People

(Reporter: Oswald Buddenhagen, Unassigned)

Tracking

({qawanted})

1.8 Branch
x86
Linux
qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

17.42 KB, application/octet-stream
Details
(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.4; Linux) KHTML/3.4.90 (like Gecko)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20050826 SeaMonkey/1.1a

i'm using an svg-enabled build. i'm trying to create a simple svg object dnd 
example - with java, not javascript. well, it does not work. :} 

Reproducible: Always

Steps to Reproduce:
1. get the attached tar-ball. it also contains a copy of the smil and svg java  
bindings for your convenience (the jre does not contain them, yet).  
2. run make  
3. start mozilla, open the java console.  
4. open either svg-java.xhtml or svg-java.xml (doesn't matter).  
  
Actual Results:  
the applet bombs out at  
EventTarget bg = (EventTarget)doc.getElementById("bgnd");  
because the node is a HTMLElement instead of an SVGElement.  
later calls will certainly bomb out, too, but it doesn't get that far, 
obviously. 

Expected Results:  
it should work. well, assuming my program is correct. :)))  
   

the same example works just fine with javascript. 
the java bindings are internally realized via liveconnect. so i guess the glue 
just needs to be adopted for other node types than html.
(Reporter)

Comment 1

12 years ago
Created attachment 195023 [details]
test application
Keywords: qawanted

Comment 2

12 years ago
==> SVG?
Assignee: general → general
Component: General → SVG
Product: Mozilla Application Suite → Core
QA Contact: general → ian
Version: unspecified → 1.8 Branch
Mozilla doesn't provide Java bindings.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.