slow textarea entry with JavaScript character count

RESOLVED WORKSFORME

Status

()

Core
DOM
--
major
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: pjs, Unassigned)

Tracking

1.8 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050819 Camino/0.9a2+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050819 Camino/0.9a2+

whenever this page is open, text entry SLOWS, and not just on that web site, but
in other tabs, too.  in fact, the entire browser seems slower.  doesnt happen in
safari.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

13 years ago
Oh, ew. The way they're doing the character counting is by polling every 200 ms
and counting characters then, as opposed to, say, counting them onkeypress.
It's slow in Firefox, too, so it's not ours.
Wevah, any idea on where this should go in Core?  Is this the caret bug or
something else or some combo?

Comment 4

13 years ago
I'm almost tempted to say that the way they're counting is dumb and that this
should be Tech Evangelism. It's an interaction with their setTimeout'd
JavaScript, at any rate, AFAICT.
-> Core:DOM for further triage
Assignee: pinkerton → general
Component: HTML Form Controls → DOM
Product: Camino → Core
QA Contact: ian
Summary: slow textarea entry → slow textarea entry with JavaScript character count
Version: unspecified → 1.8 Branch
So I can't reproduce the slowness here with a current Linux build.  Is this Mac-only?

Comment 7

13 years ago
Something has changed; it's much more responsive now. I don't know whether it's on our end or theirs, though.
Their end still has the same brain-dead code...

In any case, if this is better on Mac too, marking worksforme.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.