flash set to wmode transparent can stop setTimeout from working

RESOLVED DUPLICATE of bug 291740

Status

()

Core
Plug-ins
RESOLVED DUPLICATE of bug 291740
12 years ago
12 years ago

People

(Reporter: James, Unassigned)

Tracking

1.7 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.9) Gecko/20050711 Firefox/1.0.5

I am developing a page with a flash nav set to wmode transparent, and it uses 
an iframe, and inside the iframe javascript to scroll the iframe up and down 
using a setTimeout.

when you press the down arrow I coded, it starts a timeout that scrolls the 
page down every tenth of a sec, until you release the arrow and it clears the 
timeout, to stop scrolling.

the timeout will work perfectly while the flash nav is still loading, but once 
the nav is loaded and starts to open up (and put load on the wmode transparent 
thing) the timeouts stop working. if I right click on the flash movie and 
press rewind, then the timeouts start working again. if I remove the wmode = 
transparent, everything works fine.

this bug can only be reproduced if you have a flash file that is complicated 
enough.

Reproducible: Sometimes

Steps to Reproduce:
1.make a flash movie and put it in a webpage, with wmode set to transparent
2.make a javascript timeout, like
function pageScroll() {
	count++;
    	document.myform.mytext.value = count;
    	scrolldelay = setTimeout('pageScroll()',100); // scrolls every 100 
milliseconds
}
3. make a form to check stuff is happening - the myform.mytext thing
4. try have the timeout going on at the same time as a complex flash movie in 
wmode=transparent, the problem only occurs when there is enough things on 
stage in a flash movie.

Actual Results:  
the timeouts wouldnt work when the flash was fully displaying, but once the 
flash was rewinded to a frame where there was little on stage the timeouts 
would pick up where they left off

Expected Results:  
they should have continually worked no matter what flash was doing (this works 
in IE, but has the same bug in netscape)

um maybe this is something about if flash tries to take too many resources, it 
gets given too many and the javascript is ignored? just a guess.. but it isnt 
slowing down my processor or anything
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
Version: unspecified → 1.7 Branch
Reporter: A better testcase is needed. Please provide a link.

I've seen setTimeout stop working on IE due to resource issues. Perhaps Windows
has a timer issue when resource load is high.
Yes, this is a known issue.
I'm duping this to bug 291740, because that bug has some nice testcases, although it doesn't fit the description of this bug.
However, a lot of the ui in Firefox is also timer related, so it is very likely (almost certainly) the same bug.

*** This bug has been marked as a duplicate of 291740 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.