Error Console points to wrong position in source text

RESOLVED WONTFIX

Status

Toolkit Graveyard
Error Console
RESOLVED WONTFIX
12 years ago
10 months ago

People

(Reporter: peterv, Unassigned)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
The pointer in messages in the JS console is not connected to the line and
points to the wrong position in the source text (see attached screenshot). I
believe this is because the line and the pointer are constructed with labels
(one for the line and one for the pointer) and labels get a default left and
right margin. We probably need to set the right margin on the line's label and
the left margin on the pointer's label to 0.
I only tested this on OS X with pinstripe, no idea if other platforms/themes
have the same issue.
(Reporter)

Comment 1

12 years ago
Created attachment 195146 [details]
Screenshot

Comment 2

12 years ago
I'll check it out
Assignee: nobody → kevin

Updated

11 years ago
Summary: Javascript console points to wrong position in source text → Error Console points to wrong position in source text

Comment 3

11 years ago
Created attachment 229265 [details] [diff] [review]
remove the space between dots and caret

... and make sure that the caret really point to the correct location.
Assignee: kevin → zeniko
Status: NEW → ASSIGNED
Attachment #229265 - Flags: review?(mconnor)

Updated

10 years ago
Attachment #229265 - Flags: review?(mconnor)

Updated

10 years ago
Assignee: zeniko → nobody
Status: ASSIGNED → NEW
OS: Mac OS X → All
Hardware: Macintosh → All
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
Depends on: 490886

Updated

8 years ago
Blocks: 490886
No longer depends on: 490886
The Error Console has been removed in favor of the Browser Console (see Bug 1278368), and the component is going to be removed.  If this bug is also relevant in the Browser Console, please reopen and move this into Firefox -> Developer Tools: Console.
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → WONTFIX

Comment 5

10 months ago
I am mass-reopening and re-componenting every single one of the Toolkit:Error Console bugs that appear to have been closed without anyone even *glancing* at whether they were relevant to the Browser Console.

If you want to close a whole bunch of old bugs -- FOR ANY REASON -- it is YOUR RESPONSIBILITY to check EVERY SINGLE ONE OF THEM and make sure they are no longer valid.  Do not push that work onto the bug reporters.

(It's okay to close bugs that haven't been touched in years when they don't have enough information for you to figure out whether the problem is still relevant to the current software - the reporter probably isn't coming back to clarify.  But that is the ONLY situation where it is okay.)

(I'm going to have to do this in two steps because of the way the "change several bugs at once" form works.  Apologies for the extra bugspam.)
Status: RESOLVED → REOPENED
Component: Error Console → Developer Tools: Console
Product: Toolkit → Firefox
Resolution: WONTFIX → ---
The Error Console feature was removed entirely from the tree in Bug 1278368 and the bugzilla component is now being removed. We’ve migrated bugs that seem to also affect the Browser Console into the devtools component, please move this over if it was missed.
Status: REOPENED → RESOLVED
Last Resolved: 10 months ago10 months ago
Component: Developer Tools: Console → Error Console
Product: Firefox → Toolkit
Resolution: --- → WONTFIX
(Assignee)

Updated

10 months ago
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.