when single-clicking in the location bar, all text in location bar is selected instead of the curser being placed where clicked

RESOLVED DUPLICATE of bug 233977

Status

()

Firefox
Address Bar
RESOLVED DUPLICATE of bug 233977
13 years ago
13 years ago

People

(Reporter: gabe, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

If you go to any webpage, then atempt to click somewhere in the location bar to
edit the url, all the text in the location bar is selected instead of the curser
being placed where you want to edit.  For example, say you accidentl went to
http://www.mozzilla.org and clicked after one of the z's to delete it, the whole
url would be selected and you would have to click after the z again.  This is
very anoying and counter-intuitive behavior.

Reproducible: Always

Steps to Reproduce:
1. Go to any website.
2. When site is loaded, click somwhere in location bar.

Actual Results:  
Entire text in location bar was selected.

Expected Results:  
Cursor should have been placed at location clicked.
Already fixed for the next version.

*** This bug has been marked as a duplicate of 233977 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.