Asterisk (*) no longer Expands All Threads

RESOLVED FIXED in Thunderbird2.0

Status

Thunderbird
Mail Window Front End
--
minor
RESOLVED FIXED
13 years ago
10 years ago

People

(Reporter: Ashley Bischoff (blog at handcoding.com), Assigned: Scott MacGregor)

Tracking

({fixed-seamonkey1.0, fixed1.8.1, regression})

Trunk
Thunderbird2.0
x86
All
fixed-seamonkey1.0, fixed1.8.1, regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050906 Firefox/1.6a1 (bangbang023)
Build Identifier: Thunderbird version 1.6a1 (20050907)

Expand All Threads has the hotkey "*"; that used to work but doesn't anymore.

Reproducible: Always

Steps to Reproduce:
1. View a mail folder which has threaded messages (such as your Bugzilla folder,
if you have one)
2. Make sure View -> Sort By -> Threaded is selected
3. Hit the asterisk.

Actual Results:  
Nothing

Expected Results:  
All threads are expanded :).

Selecting "Expand All Threads" through the menu still works (View -> Threads ->
Expand All Threads). 

Possibly in the same vicinity: bug 64426 (Expand All Threads to remember its
state), though that one isn't a recent regression.

Comment 1

13 years ago
What's the last version you ran where this worked?  I'm seeing it work OK with 
1.6a1-0904.
Severity: normal → minor
Keywords: regression
(In reply to comment #1)
> What's the last version you ran where this worked?  I'm seeing it work OK with 
> 1.6a1-0904.

I'm not sure, off the top of my head, but I'll try progressively downgrading to
check on that.
(In reply to comment #2)
> I'm not sure, off the top of my head, but I'll try progressively downgrading to
> check on that.

Mike: I downgraded from one nightly build to another until the bug disappeared.
Here're my findings:

* 2005-08-26-09 - Ok
* 2005-08-30-07 - Ok
* 2005-08-31-12 [X]
* 2005-09-01-09 [X]
* 2005-09-04-11 [X]
* 2005-09-05-09 [X]

I'm not sure what's going on with your 0904 build ;). Are you running the trunk
builds? Also, when you go into a folder with threaded messages, you may need to
manually contract a thread (with the "-" sign) before hitting the asterisk key
-- just so that there's a thread /to/ expand.
Version: unspecified → Trunk

Comment 4

13 years ago
Same for SeaMonkey on Linux. 
It worked with 2005083009 and doesn't with 20050903.
I'm missing intermediate builds. 

Comment 5

13 years ago
(In reply to comment #4)
> Same for SeaMonkey on Linux.

Yes.

> It worked with 2005083009 and doesn't with 20050903.
> I'm missing intermediate builds.

I have some. :)

The regression occured for my selfcompiled linux between
200508300919 and 200508310816 CEST

Comment 6

13 years ago
(In reply to comment #5)

> The regression occured for my selfcompiled linux between
> 200508300919 and 200508310816 CEST

Hm, that could have been clearer a bit. The dates were taken immediately after
the CVS-update. And i should have given more information about my User-Agent.
Currently it is
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20050910 SeaMonkey/1.1a

Comment 7

13 years ago
Checkins in regression timeframe (this also regressed in SeaMonkey btw), based
that it work in official 2005-08-30 06:00 builds and broke 2005-08-31 08:16 CEST:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=MozillaTinderboxAll&branch=HEAD&branchtype=match&filetype=match&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2005-08-30+05%3A00%3A00&maxdate=2005-08-31+01%3A00%3A00&cvsroot=%2Fcvsroot
OS -> All

(Since I'm seeing this on Win2k & XP, while others are seeing it on Linux.)
OS: Windows XP → All
Dainis, I think this is yours...
Flags: blocking1.9a1?

Comment 10

13 years ago
Created attachment 195717 [details] [diff] [review]
Patch to fix accesskey problem (not verified)

This should fix the problem with "*", "\" and "-" acceskeys in Thunderbird.
Unfortunately I can not build the Thunderbird at the moment to verify it. I
would appreciate if someone else tries this.
Attachment #195717 - Flags: superreview?(neil.parkwaycc.co.uk)
Attachment #195717 - Flags: review?(mscott)

Comment 11

13 years ago
Comment on attachment 195717 [details] [diff] [review]
Patch to fix accesskey problem (not verified)

The new keys don't need ids. Also afaik this file doesn't need superreview.
Attachment #195717 - Flags: superreview?(neil.parkwaycc.co.uk)

Comment 12

13 years ago
Created attachment 196140 [details] [diff] [review]
Suite version (checked in)
Attachment #196140 - Flags: superreview?(bienvenu)
Attachment #196140 - Flags: review?(mnyromyr)

Updated

13 years ago
Attachment #196140 - Flags: superreview?(bienvenu)
Attachment #196140 - Flags: superreview+
Attachment #196140 - Flags: review?(mnyromyr)
Attachment #196140 - Flags: review+

Comment 13

13 years ago
Comment on attachment 196140 [details] [diff] [review]
Suite version (checked in)

oops, clearing r+
Attachment #196140 - Flags: review+ → review?(mnyromyr)
(Assignee)

Comment 14

13 years ago
Comment on attachment 195717 [details] [diff] [review]
Patch to fix accesskey problem (not verified)

please remove the id's to the new keys which as Neil pointed out, I don't think
we need.
Attachment #195717 - Flags: review?(mscott) → review+

Updated

13 years ago
Attachment #196140 - Flags: review?(mnyromyr) → review+

Updated

13 years ago
Attachment #196140 - Attachment description: Suite version → Suite version (checked in)

Comment 15

13 years ago
Created attachment 197814 [details] [diff] [review]
Thunderbird patch without duplicate key IDs
Attachment #195717 - Attachment is obsolete: true
(Assignee)

Updated

13 years ago
Attachment #197814 - Flags: superreview+
Comment on attachment 196140 [details] [diff] [review]
Suite version (checked in)

First a=me.

Why is oncommand not properly indented?

Comment 17

13 years ago
Comment on attachment 196140 [details] [diff] [review]
Suite version (checked in)

a=me for SM1.0b on SM only part of code, 2nd needed one - with indentation perhaps?

Comment 18

13 years ago
SeaMonkey-only portion of patch checked in to the 1.8 branch.
Whiteboard: fixed-seamonkey1.0
(Reporter)

Updated

13 years ago
Blocks: 236849

Comment 19

13 years ago
tb fix checked in.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Assignee)

Comment 20

13 years ago
the thunderbird only portion is now also on the 1.8.1 branch for thunderbird 2.0
Keywords: fixed1.8.1
Target Milestone: --- → Thunderbird2.0
Keywords: fixed-seamonkey1.0
Whiteboard: fixed-seamonkey1.0
Flags: blocking1.9a1?
No longer blocks: 236849
You need to log in before you can comment on or make changes to this bug.