wrong display of html entities inside a textarea

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: David Blanco, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

When displaying htmlentities like "{" inside a textarea, firefox treats
them different if they are between quotes or if they are alone. Two examples:

inside a textarea, this is displayed as a curly brace:
>font size="2"< {TEMPLATE_VAR} >/font<

inside a textarea, this is displayed as the curly brace keycode:
>font size="2"<{TEMPLATE_VAR}>/font<

I think that the right behavior is the first, converting keycodes in its
equivalents, well?

sorry about my english ;-)

Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

12 years ago
The 2 examples below well posted :-)

When displaying htmlentities like "{" inside a textarea, firefox treats
them different if they are between quotes or if they are alone. Two examples:

inside a textarea, this is displayed as a curly brace:
<font size="2"> &#123;TEMPLATE_VAR&#125; </font>

inside a textarea, this is displayed as the curly brace keycode:
<font size="2">&#123;TEMPLATE_VAR&#125;</font>
(Reporter)

Comment 2

12 years ago
please delete this bug
sorry for the inconvenient
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID

Comment 3

12 years ago
*** Bug 307483 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.