Send Link ... truncates URL at question mark character (emailing via Eudora)

RESOLVED INVALID

Status

()

RESOLVED INVALID
13 years ago
8 years ago

People

(Reporter: mscullin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Using File/Send Link ... on a page that contains a question mark in its URL
results in a mail message with a truncated URL. The truncation occurs at the
question mark. Many ASP or other actively-created pages contain a question mark
as the delimiter for the page-specific data in the URL. I am using Eudora 6.2. I
have no other mail program to try it on.

Reproducible: Always

Steps to Reproduce:
1. Go to a page with a '?' in its URL, such as
http://www.informationweek.com/showArticle.jhtml?articleID=170700839 
2. Use File/Send Link ... to create an email message with the URL of the page.

Actual Results:  
The URL in the message is truncated to
http://www.informationweek.com/showArticle.jhtml


Expected Results:  
Put the entire URL into the message.

If this turns out to be a problem in Eudora and not Firefox, please let me know
at mscullin@htva.net so I can inform Qualcomm. Sorry I have no way to test othe
mailers.
I can work around this by Copying the URL to the clipboard, then using Send Link
to create a message, then replacing the short URL with the Copied one. If I
remember to check for a question mark.

Comment 1

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050907
Firefox/1.6a1

Works for me in trunk using Thunderbird. Could you test this using the latest
builds of Firefox? If you're still seeing this then it's probably an issue with
Eudora. http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla1.8/

Comment 2

13 years ago
WFM with Mozilla 1.7.10, Mozilla 1.8b1 and Deer Park a2/Mozilla 1.8b1.

Comment 3

13 years ago
After tolerating this INCREDIBLY ANNOYING lack of basic functionality for a long
time I am very disapointed to see this bug with an unconfirmed status.

I thought I had looked up bugzilla before and seen a bug listed for this. I
assumed it was going to be fixed.

I understand Eudora users are not the majority of your users but this should be
fixed. If properly configured Eudora is one of the most secure and effective
email clients out there. People should be encouraged to use Eudora and Firefox
to improve the security of their net experience.

Please fix this bug.

Comment 4

13 years ago
reporter (Michael), to check if this is an Eudora problem, open IE (or another
browser) and use its Send Link function

Comment 5

13 years ago
(In reply to comment #4)
> reporter (Michael), to check if this is an Eudora problem, open IE (or another
> browser) and use its Send Link function

Confirmed: this is a Firefox-only problem. 

If IE can do this, why can't Firefox? 

If IE can do this, it's *not* a Eudora problem.
(Reporter)

Comment 6

13 years ago
This behavior disappeared with the latest version of FireFox. Still unknown where the bug was, but probably was FireFox.
Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 7

13 years ago
Well it hasn't disappeared for me and I have the latest version.

Do I now have to open a new bug?

Comment 8

13 years ago
pd, which version are you using?
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 9

13 years ago
At present I am using Eudora version 6.0.3.0 with Firefox 1.5.0.3

I've had this problem with several different versions of Eudora.

The issue *still* remains (I just re-tested it).

Perhaps it might help to look at the SendStory extension since this seems to be able to send a full URL without problems:

https://addons.mozilla.org/firefox/489/

The other possibility is that I have Eudora configured for extra security. Most people probably leave it configured as default. To do this is to expose oneself to all the Internet Explorer security nightmares since according to Tools -> Options -> Viewing Mail -> "Use Microsoft's viewer", Eudora uses Internet Exploder by default. I have this disabled and a few other 'features' disabled that force Eudora into an old-style plain-text-only scenario.

Comment 10

13 years ago
OK. So I looked at this code and it's not a problem in our code. We're sending the fully encoded URI to the OS, so it's in what Eudora decides to do with that URI that's the problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → INVALID

Comment 11

13 years ago
Any idea why this is not a problem in Internet Exploder then?

Perhaps IE is using a different method/API call to achieve the same thing? Maybe Fx could use this as well?

Otherwise time to hassle Qualcomm I suppose.
You need to log in before you can comment on or make changes to this bug.