Interdiff feature fails if ANY file in the patch has rev'ed between patches

RESOLVED DUPLICATE of bug 210407

Status

()

RESOLVED DUPLICATE of bug 210407
13 years ago
13 years ago

People

(Reporter: nelson, Unassigned)

Tracking

Details

(URL)

Consider two patches, each of which patches the same set of multiple source
files, in the same order.  The base revision number of ONE of the source 
files in those two patches is different between the two patches.  When one
attempts to view the differences between those two patches with buzilla's
interdiff feature, one might expect the result to show the differences 
between all the files *except* the one source file whose version number 
was not the same in the two patches.  

However what actually happens is that the result shows only the diffs 
between the FIRST file in each of the two patches, and does NOT show the
diffs for any of the other files, even the ones for which the version
numbers were unchanged.

This problem is seen in the URL
https://bugzilla.mozilla.org/attachment.cgi?oldid=194281&action=interdiff&newid=195237&headers=1

The two patches being diffed, which may be seen at 
https://bugzilla.mozilla.org/attachment.cgi?id=194281&action=diff
https://bugzilla.mozilla.org/attachment.cgi?id=195237&action=diff
patch the same set of 11 files, in the same order.  Both patches were
produced with "cvs diff -u5" in the same directory.  However, one of
the files, the 7th one of the 11 files, changed version numbers between
the two patches.  A checkin was made to that file that did not affect
the patch at all, except that it changed the base version number given
in the diff output.  This one change causes the Interdiff feature to 
show the diffs for only 1 of the 11 files (the first one).  

Expected result: see diffs for 10 of the 11 files, but not the
one file whose version number changed.
Actual result: see diffs for only one of the 11 files, the first one in
the patch.

Comment 1

13 years ago
looks like a dupe of bug 210407.
(Reporter)

Comment 2

13 years ago
Agreed.  

*** This bug has been marked as a duplicate of 210407 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.