If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Bookmarks menu gets truncated when deleting bookmarks to fit the list on one screen

RESOLVED DUPLICATE of bug 295924

Status

()

Firefox
Menus
RESOLVED DUPLICATE of bug 295924
12 years ago
12 years ago

People

(Reporter: Asher, Unassigned)

Tracking

1.5.0.x Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

This issue occurs when you have a bookmarks menu full of items, enough of them
so the menu "overflows" and requires you to scroll down to view the ones at the
bottom.

I started to delete these items at the bottom so the menu would fit neatly on
one page, rather than having to scroll.

After I deleted a couple of the items at the bottom, I noticed that the menu
began getting truncated -- the top position of the menu was the same as when
there was many more items on the menu, so much of the top part of the menu was
hidden from view without a scrollbar to view it.  Using the mouse to scroll up
fixes this issue, but this should be done automatically once enough entries are
deleted to fit the menu all on one page.

Reproducible: Always
(Reporter)

Updated

12 years ago
Version: unspecified → 1.5 Branch
(Reporter)

Comment 1

12 years ago
Created attachment 195376 [details]
example

This shows the progression of the test case: the first menu on the left is what
it looks like when opened with an overflowed menu, with the scrollbars.

The second menu in the middle is what it looks like when I scroll it down a
bit.

The last menu on the right is what it looks like after I delete a few of the
entries at the bottom of the list to try to fit the menu all on one screen. 
Notice that the top part of the menu is truncated and the bottom part has
whitespace.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050908
Firefox/1.6a1 ID:2005090821

I have seen this before but after a browser restart the menu always displayed
correctly.

*** This bug has been marked as a duplicate of 295924 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.