Closed Bug 307673 Opened 15 years ago Closed 15 years ago

Problems with displaying a list formatted with "display: inline" in text direction rtl and/or with heberw characters.

Categories

(Firefox :: General, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 178991

People

(Reporter: uellue.unterwegs, Unassigned)

References

()

Details

(Keywords: rtl)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050715 Firefox/1.0.6 SUSE/1.0.6-4.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050715 Firefox/1.0.6 SUSE/1.0.6-4.1

The example page shows some lists which are formatted with "display: inline". If
they consist of latin characters and are "ltr", theer's no problem. If the list
consists of heberw characters or has text direction "rtl", the margins are not
displayed correctly.

If the list is nested, consists of latin characters and is displayed "rtl", or
if the list is nested, consists of heberw characters and is displayed "ltr", the
links in the inner list items are not clickable.

The error is confirmed with firefox 1.0.4 and 1.5 Beta 1 on OS X and with
firefox 1.0.6 on Linux (SuSE 9.2). 

Greetings,
Dieter

Reproducible: Always

Steps to Reproduce:
1. Make sure you have got a heberw font
2. Go to http://gallue.sourceforge.net/firefoxkaputt.utf8.html
3. Enjoy! ;)

Actual Results:  
Some links are not clickable, and some margins are incorrect.

Expected Results:  
All links should be clickable and the margins should be equal for every text
direction and character set.
The part about links not working is essentially a duplicate of bug 178991 (the
neutral character in this case is a space).
The part about incorrect margins is a duplicate of bug 121633.


*** This bug has been marked as a duplicate of 178991 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Mass-assigning the new rtl keyword to RTL-related (see bug 349193).
Keywords: rtl
You need to log in before you can comment on or make changes to this bug.