using keyboard to scroll through page doesn't work correctly if "Allow text to be selected with the keyboard" is active

RESOLVED INVALID

Status

()

Firefox
Keyboard Navigation
--
major
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: bytesmythe, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

When the option to select text with the keyboard is active, the location caret
can get "stuck" in certain parts of the page. If the option is not active, page
scrolling works normally.

Reproducible: Always

Steps to Reproduce:
1. Make sure that the advanced option "Allow text to be selected with the
keyboard" is enabled.
2. Visit the referenced page.
3. Click in any non-anchored visible text (such as "What's New In Firefox")
4. Hold the down arrow key and verify that the page scrolls correctly.
5. Using the arrow keys or page up/down keys, scroll either to the very top or
very bottom of the page.
6. Using the opposite key from the previous step, scroll the other way. 

Actual Results:  
The scrolling completely skipped the middle of the page.

Expected Results:  
Scrolling should go smoothly between all the visible text on the page,
regardless of what the underlying HTML looks like.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b4) Gecko/20050908
Firefox/1.4 ID:2005090806

Confirmed

focus/select appears to be completely lost at some point

(failed to find a dupe)
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

12 years ago
First off, i do NOT have "Allow text to be selected with the keyboard" active

I am having numerous problems with keyboard navigation in Firefox 1.5.0.1 which I will detail here. If I should have this in a different bugzilla ticket, I will post it there.

These problems seem intermittent, but all seem related to a blinking cursor appearing when I am trying to use the keyboard to navigate pages. If I hit page-up or page-down, it will not work until I click on the viewable area of a webpage. Ideally, if Firefox has focus, page up and page down should still work for whatever page is being viewed. Aside from that, the mouse scroll wheel will not work unless the mouse is over the page you are viewing EVEN THOUGH Firefox is the active window, and the tab is active. If the cursor is on the address bar or on the desktop (if Firefox is not full screened) the scroll wheel will not work. 

End and Home also refuse to work; this is where I believe that blinking cursor comes into play. If I hit end or home, rather than going to the end or beginning of the page, instead it goes to the beginning and end of a single word (whichever that blinking cursor is near)

Finally, occasionally when using page down, the view will stay viewing the same area. For instance, if I hold down page down, I can see the screen refreshing as if it is paging down, although the view remains the same.

Using Firefox 1.5.0.1

Comment 3

12 years ago
(In reply to comment #2)
> the mouse scroll wheel will
> not work unless the mouse is over the page you are viewing EVEN THOUGH Firefox
> is the active window, and the tab is active. If the cursor is on the address
> bar or on the desktop (if Firefox is not full screened) the scroll wheel will
> not work. 
> 

Disregard the previous post except for the mouse-wheel bit. After the Firefox auto-update, I hadn't deleted my profile and made a new one. Just did that and the problem seems to be gone.

Updated

12 years ago
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.