Different font rendering in comparison with Firefox 1.0.6

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
13 years ago
7 years ago

People

(Reporter: robert, Assigned: blizzard)

Tracking

({fonts})

1.8 Branch
x86
Linux
fonts

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(5 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

Linux Firefox 1.5b1 render a different font on this site than when Firefox 1.0.6
is used. The 1.0.6 font is better looking and i think that was the page designer
intention. A comparison screenshot will be added to the bug.

Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

13 years ago
Created attachment 195409 [details]
Comparing font rendering with 1.0.6 and 1.5b1

This was taken using the original Firefox releases from Mozilla.org, in order
to no compare custom Firefox from the Linux distribution with Firefox 1.5b1.
Running on Fedora Core 4
(Reporter)

Comment 2

13 years ago
oops forgot to indicate 1.5 branch
Version: unspecified → 1.5 Branch
Assignee: nobody → blizzard
Component: General → GFX: Gtk
Product: Firefox → Core
QA Contact: general → gtk
Version: 1.5 Branch → 1.8 Branch

Comment 3

13 years ago
Go to http://members.ij.net/mrmazda/auth/dpi-screen-window.html and see if both report the same DPI.
(Reporter)

Comment 4

13 years ago
Created attachment 206277 [details]
DPI comparation

Both report 96 DPI.. but the selected font is different. The first table is firefox 1.5, the other one firefox 1.0.7

Comment 5

13 years ago
I saw this on a Red Hat system the other day after upgrading from 1.0.7 to 1.5.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: 1.8 Branch → Trunk
Keywords: fonts

Comment 6

13 years ago
Looks to me like your 1.5 profile's default sans-serif font is Nimbus Sans L, and your 1.0.6 profile's default sans-serif font is Bitstream Vera Sans. Vera is considerably larger for any given nominal size than Nimbus. Vera @ 16px is about the same size as Nimbus @ 18px.
(Reporter)

Comment 7

13 years ago
Both version was tested using a nre profile, so it is using default font mappings. I found another font rendering problem:

When no lang attribute is used Japanese characters are shown with a different font, one that is not scalable. when using the attribute, the rigth font is used. That never happened on Firefox 1.0.x. See the attached files
(Reporter)

Comment 8

13 years ago
Created attachment 206779 [details]
testcase without lang attribute
(Reporter)

Comment 9

13 years ago
Created attachment 206780 [details]
testcase with lang attribute
(Reporter)

Comment 10

13 years ago
Created attachment 206781 [details]
Screenshot with both cases shown
(Reporter)

Comment 11

13 years ago
Changing version to 1.8 branch because it exists on released Firefox 1.5
Version: Trunk → 1.8 Branch
Does this bug occur in a recent trunk build?
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
Product: Core → Core Graveyard
Both test cases render identically for me with FF8.  Closing.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.