Keyboard shortcuts for switching tabs stop working

RESOLVED DUPLICATE of bug 290177

Status

()

RESOLVED DUPLICATE of bug 290177
13 years ago
12 years ago

People

(Reporter: msridhar, Unassigned)

Tracking

1.5.0.x Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 07/05, URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050909 Firefox/1.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050909 Firefox/1.4

When I try to edit a list on a Backpackit page, the keyboard shortcuts CTRL+PgUp
and CTRL+PgDn to switch tabs stop working.  If I click on another tab, they
start working again.

Reproducible: Always

Steps to Reproduce:
1. Run "firefox 149466.html," where the HTML file is attached.  Sometimes
firefox crashes for me if I try to open the HTML file through the menus.
2. Open a new tab with some web page.
3. Go back to the original attached page, and click the "Add item" link.
4. Press CTRL+PgUp

This is probably easier to reproduce if you have a Backpackit account and make
your own list.

Actual Results:  
Nothing

Expected Results:  
Should have switched to new tab.
(Reporter)

Comment 1

13 years ago
Created attachment 195445 [details]
Page that shows problem
(Reporter)

Updated

13 years ago
Version: unspecified → 1.5 Branch

Comment 2

13 years ago
In fact, when the keyboard focus is inside a text input field, ctrl+PgUp and ctrl+PgDn sometimes stop working.  Instead of changing tabs, it brings up the saved form data selector.  The Alt-N keys do work, but I find that I prefer to use the other key combinations (with a lot of tabs, it's hard to know which number you want to switch to.)

This is a new problem with the 1.5 branch.  With google as my home page, I run into this all the time since I upgraded, because the query field automatically grabs keyboard focus when you load the page.

The component should probably be changed to 'keyboard navigation', but I don't have the power to do that.  I hope someone will notice this, as it's my #1 pet peave about Firefox 1.5.

Comment 3

12 years ago
I don't mean to be a pest, but this bug continues to drive me absolutely crazy.

I have confirmed that the problem does not occur in the latest mozilla nightly, but does still occur in the latest firefox nightly.  I'd be willing to look into this myself if someone would offer a few pointers on what needs to be done to correct it.
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 07/05
(Reporter)

Comment 5

12 years ago
(In reply to comment #4)
> Reporter, do you still see this problem with the latest Firefox 2? If not, can
> you please close this bug as WORKSFORME. Thanks!
> 

I still see this problem using Firefox 2.0.0.4.  The CTRL+PgUp and CTRL+PgDn keyboard shortcuts don't work when the focus is in a text area, but CTRL+Tab and CTRL+SHIFT+Tab still work.  It looks to me like this bug is a duplicate of bug 290177, so I'll mark it that way.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 290177
You need to log in before you can comment on or make changes to this bug.