Closed Bug 307763 Opened 15 years ago Closed 14 years ago

xul hboxes -with 100% margin- nested inside inline boxes are very slow

Categories

(Core :: Layout, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: martijn.martijn, Unassigned)

References

()

Details

(Keywords: perf, regression, testcase, Whiteboard: [reflow-refactor])

This is a follow-up for bug 277208 (please for more info, see also there).

The url testcase is very slow with rendering, that should not happen.

It wasn't always slow, it was fast in 20040928 build, it was slow in 20040929
build. Probably a regression from fixing bug 258513.
Keywords: perf
Whiteboard: [reflow-refactor]
Blocks: 313219
Ok, there was a regression between 2005-12-15 and 2005-12-16, which made the testcase not show this bug.
It was probably caused by the patch for bug 307992 and is probably the same as  bug 321402.
But it is fixed now with the reflow branch landing and with builds after the reflow branch landing, the testcase isn't slow anymore, so marking fixed.
Status: NEW → RESOLVED
Closed: 14 years ago
Depends on: reflow-refactor
Resolution: --- → FIXED
Adding in-testsuite? nomination per bz's request in m.d.t.l. Sorry for the bugspam.
Flags: in-testsuite?
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.